GHSA-ghc5-95c2-vwcv
GHSA-ghc5-95c2-vwcv · Auth0 Symfony SDK has Insufficient Entropy in Cookie Encryption
This page contains facts from public vulnerability sources. Check the original advisory before updating.
### Impact In applications built with the Auth0 PHP SDK, cookies are encrypted with insufficient entropy, which may result in threat actors brute-forcing the encryption key and forging session cookies. ### Am I Affected? Consumers are affected if their application meets the following preconditions: - It uses the Auth0 Symfony SDK, versions between 5.0.0 and 5.7.0 - Auth0 Symfony SDK using the Auth0-PHP SDK versions between 8.0.0 to 8.18.0. ### Resolution Upgrade Auth0/symfony-auth0 to version 5.8.0 or greater.
CVSS 8.2 · High · Fix available
- Published
- Updated
Stack: php
Affected products and versions
auth0/symfony Packagist
- Versions
- 5.0.0
- 5.1.0
- 5.2.0
- 5.2.1
- 5.2.2
- 5.2.3
- 5.3.0
- 5.3.1
- 5.4.0
- 5.4.1
- 5.5.0
- 5.6.0
- 5.7.0
- Affected ranges
- ECOSYSTEM: ≥ 5.0.0, < 5.8.0
Update to 5.8.0