GHSA-gr4j-r575-g665
GHSA-gr4j-r575-g665 · Cross-Site Scripting in highcharts
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Versions of `highcharts` prior to 7.2.2 or 8.1.1 are vulnerable to Cross-Site Scripting (XSS). The package fails to sanitize `href` values and does not restrict URL schemes, allowing attackers to execute arbitrary JavaScript in a victim's browser if they click the link.
CVSS 8.7 · High · Fix available
- Published
- Updated
Stack: node
Affected products and versions
highcharts npm
- Affected ranges
- SEMVER: < 7.2.2
Update to 7.2.2
highcharts npm
- Affected ranges
- SEMVER: ≥ 8.0.0, < 8.1.1
Update to 8.1.1