GHSA-gvpp-6jrj-5pqc
GHSA-gvpp-6jrj-5pqc · Zend-Form vulnerable to Cross-site Scripting
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Many Zend Framework 2 view helpers were using the escapeHtml() view helper in order to escape HTML attributes, instead of the more appropriate escapeHtmlAttr(). In situations where user data and/or JavaScript is used to seed attributes, this can lead to potential cross site scripting (XSS) attack vectors. Vulnerable view helpers include: - All `Zend\Form` view helpers. - Most `Zend\Navigation` (aka `Zend\View\Helper\Navigation\*`) view helpers. - All "HTML Element" view helpers: `htmlFlash()`, `htmlPage()`, `htmlQuickTime()`. - `Zend\View\Helper\Gravatar`
CVSS 6.1 · Medium · Fix available
- Published
- Updated
Stack: php
Affected products and versions
zendframework/zend-form Packagist
- Versions
- 2.0.3
- 2.0.4
- 2.0.5
- 2.0.6
- 2.0.7
- 2.0.8
- 2.1.0
- 2.1.1
- 2.1.2
- 2.1.3
- 2.1.4
- 2.1.5
- 2.1.6
- 2.2.0
- 2.2.0rc1
- 2.2.0rc2
- 2.2.0rc3
- 2.2.1
- 2.2.2
- 2.2.3
- 2.2.4
- 2.2.5
- 2.2.6
- Affected ranges
- ECOSYSTEM: ≥ 2.0.0, < 2.2.7
Update to 2.2.7
zendframework/zend-form Packagist
- Versions
- 2.3.0
- Affected ranges
- ECOSYSTEM: ≥ 2.3.0, < 2.3.1
Update to 2.3.1
Original sources
- https://github.com/zendframework/zend-form/commit/6fe40314e8e3477494aadd03d62573bd1c212bd1
- https://github.com/zendframework/zend-form/commit/d7a1f5bc4626b1df990391502a868b28c37ba65d
- https://github.com/zendframework/zend-form/commit/fd43a951460c4bc60c77a566129705f6bdb9c61b
- https://framework.zend.com/security/advisory/ZF2014-03
- https://github.com/FriendsOfPHP/security-advisories/blob/master/zendframework/zend-form/ZF2014-03.yaml
- https://github.com/zendframework/zend-form
- https://osv.dev/vulnerability/GHSA-gvpp-6jrj-5pqc