p PatchFirst

GHSA-h25m-26qc-wcjf

GHSA-h25m-26qc-wcjf · Next.js HTTP request deserialization can lead to DoS when using insecure React Server Components

This page contains facts from public vulnerability sources. Check the original advisory before updating.

A vulnerability affects certain React Server Components packages for versions 19.0.x, 19.1.x, and 19.2.x and frameworks that use the affected packages, including Next.js 13.x, 14.x, 15.x, and 16.x using the App Router. The issue is tracked upstream as [CVE-2026-23864](https://github.com/facebook/react/security/advisories/GHSA-83fc-fqcc-2hmg). A specially crafted HTTP request can be sent to any App Router Server Function endpoint that, when deserialized, may trigger excessive CPU usage, out-of-memory exceptions, or server crashes. This can result in denial of service in unpatched environments.

CVSS 7.5 · High · Fix available

Published
Updated

Stack: node

Affected products and versions

  • next npm

    Affected ranges
    • SEMVER: ≥ 13.0.0, < 15.0.8

    Update to 15.0.8

  • next npm

    Affected ranges
    • SEMVER: ≥ 15.1.1-canary.0, < 15.1.12

    Update to 15.1.12

  • next npm

    Affected ranges
    • SEMVER: ≥ 15.2.0-canary.0, < 15.2.9

    Update to 15.2.9

  • next npm

    Affected ranges
    • SEMVER: ≥ 15.3.0-canary.0, < 15.3.9

    Update to 15.3.9

  • next npm

    Affected ranges
    • SEMVER: ≥ 15.4.0-canary.0, < 15.4.11

    Update to 15.4.11

  • next npm

    Affected ranges
    • SEMVER: ≥ 15.5.1-canary.0, < 15.5.10

    Update to 15.5.10

  • next npm

    Affected ranges
    • SEMVER: ≥ 15.6.0-canary.0, < 15.6.0-canary.61

    Update to 15.6.0-canary.61

  • next npm

    Affected ranges
    • SEMVER: ≥ 16.0.0-beta.0, < 16.0.11

    Update to 16.0.11

  • next npm

    Affected ranges
    • SEMVER: ≥ 16.1.0-canary.0, < 16.1.5

    Update to 16.1.5

Original sources

Check your server →