p PatchFirst

GHSA-hhvj-mcrx-3vcf

GHSA-hhvj-mcrx-3vcf · silverstripe/framework has Cross-site Scripting vulnerability in page name

This page contains facts from public vulnerability sources. Check the original advisory before updating.

silverstripe/framework is vulnerable to XSS in Page name where the payload `"><svg/onload=alert(/xss/)>` will trigger an XSS alert.

CVSS 6.1 · Medium · Fix available

Published
Updated

Stack: php

Affected products and versions

  • silverstripe/framework Packagist

    Versions
    • 3.4.0
    • 3.4.0-rc1
    • 3.4.1
    • 3.4.1-rc1
    • 3.4.1-rc2
    • 3.4.2
    • 3.4.3
    • 3.4.3-rc1
    • 3.4.4-rc1
    Affected ranges
    • ECOSYSTEM: ≥ 3.4.0-rc1, < 3.4.4

    Update to 3.4.4

  • silverstripe/framework Packagist

    Versions
    • 3.5.0
    • 3.5.0-rc1
    • 3.5.0-rc2
    • 3.5.0-rc3
    • 3.5.1
    • 3.5.1-rc1
    • 3.5.1-rc2
    • 3.5.2-rc1
    Affected ranges
    • ECOSYSTEM: ≥ 3.5.0-rc1, < 3.5.2

    Update to 3.5.2

Original sources

Check your server →