GHSA-hx53-jchx-cr52
GHSA-hx53-jchx-cr52 · Symfony2 improper IP based access control
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Damien Tournoud, from the Drupal security team, contacted us two days ago about a security issue in the Request::getClientIp() method when the trust proxy mode is enabled (Request::trustProxyData()). An application is vulnerable if it uses the client IP address as returned by the Request::getClientIp() method for sensitive decisions like IP based access control. To fix this security issue, the following changes have been made to all versions of Symfony2: A new Request::setTrustedProxies() method has been introduced and should be used intead of Request::trustProxyData() to enable the trust proxy mode. It takes an array of trusted proxy IP addresses as its argument: ``` // before (probably in your front controller script) Request::trustProxyData(); ``` ``` // after Request::setTrustedProxies(array('1.1.1.1')); // 1.1.1.1 being the IP address of a trusted reverse proxy ``` The Request::trustProxyData() method has been deprecated (when used, it automatically trusts the latest proxy in the chain -- which is the current remote address): ``` Request::trustProxyData(); ``` ``` // is equivalent to Request::setTrustedProxies(array($request->server->get('REMOTE_ADDR'))); ``` We encourage all Symfony2 users to upgrade as soon as possible. It you don't want to upgrade to the latest version yet, you can also apply the following patches: [Patch](https://github.com/symfony/symfony/compare/fc89d6b...9ce892c.patch) for Symfony 2.0.19 [Patch](https://github.com/symfony/symfony/compare/922c201...e5536f0.patch) for Symfony 2.1.4
CVSS 5.9 · Medium · Fix available
- Published
- Updated
Stack: php
Affected products and versions
symfony/symfony Packagist
- Versions
- 2.0.4
- 2.0.5
- 2.0.6
- 2.0.7
- v2.0.10
- v2.0.11
- v2.0.12
- v2.0.13
- v2.0.14
- v2.0.15
- v2.0.16
- v2.0.17
- v2.0.18
- v2.0.9
- Affected ranges
- ECOSYSTEM: ≥ 2.0.0, < 2.0.19
Update to 2.0.19
symfony/symfony Packagist
- Versions
- v2.1.0
- v2.1.1
- v2.1.2
- v2.1.3
- Affected ranges
- ECOSYSTEM: ≥ 2.1.0, < 2.1.4
Update to 2.1.4
Original sources
- https://github.com/symfony/symfony/commit/922c2015f61a7205180d423dce1f7365cc2d8460
- https://github.com/symfony/symfony/commit/9ce892cf4395e73b136e9b5cd1fae9e91995c93b
- https://github.com/FriendsOfPHP/security-advisories/blob/master/symfony/symfony/2012-11-29.yaml
- https://github.com/symfony/symfony
- https://symfony.com/blog/security-release-symfony-2-0-19-and-2-1-4
- https://osv.dev/vulnerability/GHSA-hx53-jchx-cr52