p PatchFirst

GHSA-j982-5jv7-v43r

GHSA-j982-5jv7-v43r · Silverstripe Form field validation message XSS vulnerability

This page contains facts from public vulnerability sources. Check the original advisory before updating.

A high level XSS risk has been identified in the encoding of validation messages in certain FormField classes. Certain fields such as the NumericField and DropdownField have been identified, but any form field which presents any invalid content as a part of its validation response will be at risk.

CVSS 6.1 · Medium · Fix available

Published
Updated

Stack: php

Affected products and versions

  • silverstripe/framework Packagist

    Versions
    • 3.0.10
    • 3.0.10-rc1
    • 3.0.11
    • 3.0.11-rc1
    • 3.0.12
    • 3.0.13
    • 3.0.14
    • 3.0.2.1
    • 3.0.3
    • 3.0.3-rc1
    • 3.0.3-rc2
    • 3.0.4
    • 3.0.5
    • 3.0.6
    • 3.0.6-rc1
    • 3.0.6-rc2
    • 3.0.7
    • 3.0.7-rc1
    • 3.0.8
    • 3.0.9
    • 3.0.9-rc1
    • 3.1.0
    • 3.1.0-beta1
    • 3.1.0-beta2
    • 3.1.0-beta3
    • 3.1.0-rc1
    • 3.1.0-rc2
    • 3.1.0-rc3
    • 3.1.1
    • 3.1.10
    • 3.1.10-rc1
    • 3.1.10-rc2
    • 3.1.11
    • 3.1.11-rc1
    • 3.1.12
    • 3.1.13
    • 3.1.13-rc1
    • 3.1.14
    • 3.1.14-rc1
    • 3.1.15
    • 3.1.16-rc1
    • 3.1.2
    • 3.1.2-rc1
    • 3.1.3
    • 3.1.3-rc1
    • 3.1.3-rc2
    • 3.1.4
    • 3.1.4-rc1
    • 3.1.5
    • 3.1.5-rc1
    • 3.1.6
    • 3.1.6-rc1
    • 3.1.6-rc2
    • 3.1.6-rc3
    • 3.1.7
    • 3.1.7-rc1
    • 3.1.8
    • 3.1.9
    • 3.1.9-rc1
    Affected ranges
    • ECOSYSTEM: ≥ 3.0.0, < 3.1.16

    Update to 3.1.16

  • silverstripe/framework Packagist

    Versions
    • 3.2.0
    • 3.2.1-rc1
    • 3.2.1-rc2
    Affected ranges
    • ECOSYSTEM: ≥ 3.2.0, < 3.2.1

    Update to 3.2.1

Original sources

Check your server →