GHSA-jqr7-5h7r-ch8p
GHSA-jqr7-5h7r-ch8p · Shopware Non-Persistent XSS in the Frontend
This page contains facts from public vulnerability sources. Check the original advisory before updating.
A non-persistent Cross-Site Scripting (XSS) vulnerability has been identified in the Shopware eCommerce platform within the frontend. This vulnerability may allow an attacker to inject and execute malicious scripts in the context of a victim's web browser.
CVSS 6.1 · Medium · Fix available
- Published
- Updated
Stack: php
Affected products and versions
shopware/shopware Packagist
- Versions
- 5.3.0
- v5.2.0
- v5.2.1
- v5.2.10
- v5.2.11
- v5.2.12
- v5.2.13
- v5.2.14
- v5.2.15
- v5.2.16
- v5.2.17
- v5.2.18
- v5.2.19
- v5.2.2
- v5.2.20
- v5.2.21
- v5.2.22
- v5.2.23
- v5.2.24
- v5.2.25
- v5.2.26
- v5.2.27
- v5.2.3
- v5.2.4
- v5.2.5
- v5.2.6
- v5.2.7
- v5.2.8
- v5.2.9
- v5.3.4
- v5.3.5
- v5.3.6
- Affected ranges
- ECOSYSTEM: ≥ 5.2.0, < 5.3.7
Update to 5.3.7
Original sources
- https://github.com/shopware5/shopware/commit/54461aa651566dc2701b873fe6bd94589604751b
- https://community.shopware.com/_detail_2048.html
- https://docs.shopware.com/en/shopware-5-en/security-updates/security-update-01-2018?category=shopware-5-en/security-updates
- https://github.com/FriendsOfPHP/security-advisories/blob/master/shopware/shopware/2018-01-22.yaml
- https://github.com/shopware5/shopware
- https://osv.dev/vulnerability/GHSA-jqr7-5h7r-ch8p