p PatchFirst

GHSA-mpqj-f4v3-334h

GHSA-mpqj-f4v3-334h · Silverstripe Cross-site scripting vulnerability in VersionedRequestFilter

This page contains facts from public vulnerability sources. Check the original advisory before updating.

A cross-site scripting vulnerability in VersionedRequestFilter has been found. If an incoming user request should not be able to access the requested stage, an error message is created for display on the CMS login page that they are redirected to. In this error message, the URL of the requested page is interpolated into the error message without being escaped; hence, arbitrary HTML can be injected into the CMS login page.

CVSS 6.1 · Medium · Fix available

Published
Updated

Stack: php

Affected products and versions

  • silverstripe/framework Packagist

    Versions
    • 3.3.2
    • 3.3.3-rc1
    • 3.3.3-rc2
    Affected ranges
    • ECOSYSTEM: ≥ 3.3.2, < 3.3.3

    Update to 3.3.3

  • silverstripe/framework Packagist

    Versions
    • 3.4.0
    • 3.4.1-rc1
    • 3.4.1-rc2
    Affected ranges
    • ECOSYSTEM: ≥ 3.4.0, < 3.4.1

    Update to 3.4.1

Original sources

Check your server →