GHSA-mwv6-3258-q52c
GHSA-mwv6-3258-q52c · Next Vulnerable to Denial of Service with Server Components
This page contains facts from public vulnerability sources. Check the original advisory before updating.
A vulnerability affects certain React packages for versions 19.0.0, 19.0.1, 19.1.0, 19.1.1, 19.1.2, 19.2.0, and 19.2.1 and frameworks that use the affected packages, including Next.js 15.x and 16.x using the App Router. The issue is tracked upstream as [CVE-2025-55184](https://www.cve.org/CVERecord?id=CVE-2025-55184). A malicious HTTP request can be crafted and sent to any App Router endpoint that, when deserialized, can cause the server process to hang and consume CPU. This can result in denial of service in unpatched environments.
CVSS 7.5 · High · Fix available
- Published
- Updated
Stack: node
Affected products and versions
next npm
- Affected ranges
- SEMVER: ≥ 13.3.0, < 14.2.34
Update to 14.2.34
next npm
- Affected ranges
- SEMVER: ≥ 15.0.0-canary.0, < 15.0.6
Update to 15.0.6
next npm
- Affected ranges
- SEMVER: ≥ 15.1.1-canary.0, < 15.1.10
Update to 15.1.10
next npm
- Affected ranges
- SEMVER: ≥ 15.2.0-canary.0, < 15.2.7
Update to 15.2.7
next npm
- Affected ranges
- SEMVER: ≥ 15.3.0-canary.0, < 15.3.7
Update to 15.3.7
next npm
- Affected ranges
- SEMVER: ≥ 15.4.0-canary.0, < 15.4.9
Update to 15.4.9
next npm
- Affected ranges
- SEMVER: ≥ 15.5.1-canary.0, < 15.5.8
Update to 15.5.8
next npm
- Affected ranges
- SEMVER: ≥ 15.6.0-canary.0, < 15.6.0-canary.59
Update to 15.6.0-canary.59
next npm
- Affected ranges
- SEMVER: ≥ 16.0.0-beta.0, < 16.0.9
Update to 16.0.9
next npm
- Affected ranges
- SEMVER: ≥ 16.1.0-canary.0, < 16.1.0-canary.17
Update to 16.1.0-canary.17