GHSA-p2h4-7fp3-cmh8
GHSA-p2h4-7fp3-cmh8 · TYPO3 Disclosure of Information about Installed Extensions
This page contains facts from public vulnerability sources. Check the original advisory before updating.
It has been discovered that mechanisms used for configuration of RequireJS package loading are susceptible to information disclosure. This way a potential attack can retrieve additional information about installed system and third party extensions.
CVSS 5.3 · Medium · Fix available
- Published
- Updated
Stack: php
Affected products and versions
typo3/cms-core Packagist
- Versions
- v8.7.10
- v8.7.11
- v8.7.12
- v8.7.13
- v8.7.14
- v8.7.15
- v8.7.16
- v8.7.17
- v8.7.18
- v8.7.19
- v8.7.20
- v8.7.21
- v8.7.22
- v8.7.7
- v8.7.8
- v8.7.9
- Affected ranges
- ECOSYSTEM: ≥ 8.0.0, < 8.7.23
Update to 8.7.23
typo3/cms-core Packagist
- Versions
- v9.0.0
- v9.1.0
- v9.2.0
- v9.2.1
- v9.3.0
- v9.3.1
- v9.3.2
- v9.3.3
- v9.4.0
- v9.5.0
- v9.5.1
- v9.5.2
- v9.5.3
- Affected ranges
- ECOSYSTEM: ≥ 9.0.0, < 9.5.4
Update to 9.5.4
Original sources
- https://github.com/TYPO3-CMS/core/commit/7960334bba1223a681283158f67a999334e88cf1
- https://github.com/TYPO3-CMS/core/commit/9453d8a8763fffa76deb6a16f6b99c0ab6f3d8f1
- https://github.com/FriendsOfPHP/security-advisories/blob/master/typo3/cms-core/2019-01-22-1.yaml
- https://typo3.org/security/advisory/typo3-core-sa-2019-001
- https://osv.dev/vulnerability/GHSA-p2h4-7fp3-cmh8