GHSA-p2v5-xcqm-4fv6
GHSA-p2v5-xcqm-4fv6 · silverstripe/taxonomy SQL Injection vulnerability
This page contains facts from public vulnerability sources. Check the original advisory before updating.
There is a vulnerability in silverstripe/taxonomy module that allows SQL injection. This affected controller (`TaxonomyDirectoryController`) is disabled by default and must be enabled by a developer for the exploit to be possible.
CVSS 7.5 · High · Fix available
- Published
- Updated
Stack: php
Affected products and versions
silverstripe/taxonomy Packagist
- Versions
- 1.3.0
- Affected ranges
- ECOSYSTEM: ≥ 1.3.0, < 1.3.1
Update to 1.3.1
silverstripe/taxonomy Packagist
- Versions
- 2.0.0
- Affected ranges
- ECOSYSTEM: ≥ 2.0.0, < 2.0.1
Update to 2.0.1
Original sources
- https://github.com/silverstripe/silverstripe-taxonomy/commit/01a5d9e04b993df507058aa53e6e18efc5ca405b
- https://github.com/silverstripe/silverstripe-taxonomy/commit/d037941e931490c33af5029c676447ed38896ee8
- https://github.com/FriendsOfPHP/security-advisories/blob/master/silverstripe/taxonomy/SS-2018-011-1.yaml
- https://github.com/silverstripe/silverstripe-taxonomy
- https://www.silverstripe.org/download/security-releases/ss-2018-011
- https://osv.dev/vulnerability/GHSA-p2v5-xcqm-4fv6