p PatchFirst

GHSA-p5c5-gmj4-g48f

GHSA-p5c5-gmj4-g48f · Cross-Site Scripting (XSS) vulnerability in typolinks

This page contains facts from public vulnerability sources. Check the original advisory before updating.

All link fields within the TYPO3 installation are vulnerable to Cross-Site Scripting as authorized editors can insert data commands by using the url scheme "data:".

Fix available

Published
Updated

Stack: php

Affected products and versions

  • typo3/cms Packagist

    Versions
    • 6.2.0
    • 6.2.1
    • 6.2.10
    • 6.2.10-rc1
    • 6.2.11
    • 6.2.12
    • 6.2.13
    • 6.2.14
    • 6.2.15
    • 6.2.16
    • 6.2.17
    • 6.2.18
    • 6.2.19
    • 6.2.2
    • 6.2.20
    • 6.2.21
    • 6.2.22
    • 6.2.23
    • 6.2.24
    • 6.2.25
    • 6.2.3
    • 6.2.4
    • 6.2.5
    • 6.2.6
    • 6.2.7
    • 6.2.8
    • 6.2.9
    Affected ranges
    • ECOSYSTEM: ≥ 6.2.0, < 6.2.26

    Update to 6.2.26

  • typo3/cms Packagist

    Versions
    • 7.6.0
    • 7.6.1
    • 7.6.2
    • 7.6.3
    • 7.6.4
    • 7.6.5
    • 7.6.6
    • 7.6.7
    • 7.6.8
    • 7.6.9
    Affected ranges
    • ECOSYSTEM: ≥ 7.6.0, < 7.6.10

    Update to 7.6.10

  • typo3/cms Packagist

    Versions
    • 8.0.0
    • 8.0.1
    • 8.1.0
    • 8.1.1
    • 8.1.2
    • 8.2.0
    Affected ranges
    • ECOSYSTEM: ≥ 8.0.0, < 8.2.1

    Update to 8.2.1

Original sources

Check your server →