p PatchFirst

GHSA-p76f-wr22-4rv6

GHSA-p76f-wr22-4rv6 · CakePHP vulnerable to Remote File Inclusion through View template name manipulation

This page contains facts from public vulnerability sources. Check the original advisory before updating.

CakePHP 2.x prior to 2.0.99, 2.1.99, 2.2.99, 2.3.99, 2.4.99, 2.5.99, 2.6.12, and 2.7.6 and 3.x prior to 3.0.15 and 3.1.4 is vulnerable to Remote File Inclusion through View template name manipulation.

Fix available

Published
Updated

Stack: php

Affected products and versions

  • cakephp/cakephp Packagist

    Affected ranges
    • ECOSYSTEM: ≥ 2.0.0, < 2.0.99

    Update to 2.0.99

  • cakephp/cakephp Packagist

    Affected ranges
    • ECOSYSTEM: ≥ 2.1.0, < 2.1.99

    Update to 2.1.99

  • cakephp/cakephp Packagist

    Affected ranges
    • ECOSYSTEM: ≥ 2.2.0, < 2.2.99

    Update to 2.2.99

  • cakephp/cakephp Packagist

    Affected ranges
    • ECOSYSTEM: ≥ 2.3.0, < 2.3.99

    Update to 2.3.99

  • cakephp/cakephp Packagist

    Versions
    • 2.4.10
    • 2.4.5
    • 2.4.6
    • 2.4.7
    • 2.4.8
    • 2.4.9
    Affected ranges
    • ECOSYSTEM: ≥ 2.4.0, < 2.4.99

    Update to 2.4.99

  • cakephp/cakephp Packagist

    Versions
    • 2.5.0
    • 2.5.1
    • 2.5.2
    • 2.5.3
    • 2.5.4
    • 2.5.5
    • 2.5.6
    • 2.5.7
    • 2.5.8
    • 2.5.9
    Affected ranges
    • ECOSYSTEM: ≥ 2.5.0, < 2.5.99

    Update to 2.5.99

  • cakephp/cakephp Packagist

    Versions
    • 2.6.0
    • 2.6.1
    • 2.6.10
    • 2.6.11
    • 2.6.2
    • 2.6.3
    • 2.6.4
    • 2.6.5
    • 2.6.6
    • 2.6.7
    • 2.6.8
    • 2.6.9
    Affected ranges
    • ECOSYSTEM: ≥ 2.6.0, < 2.6.12

    Update to 2.6.12

  • cakephp/cakephp Packagist

    Versions
    • 2.7.0
    • 2.7.1
    • 2.7.2
    • 2.7.3
    • 2.7.4
    • 2.7.5
    Affected ranges
    • ECOSYSTEM: ≥ 2.7.0, < 2.7.6

    Update to 2.7.6

  • cakephp/cakephp Packagist

    Versions
    • 3.0.0
    • 3.0.1
    • 3.0.10
    • 3.0.11
    • 3.0.12
    • 3.0.13
    • 3.0.14
    • 3.0.2
    • 3.0.3
    • 3.0.4
    • 3.0.5
    • 3.0.6
    • 3.0.7
    • 3.0.8
    • 3.0.9
    Affected ranges
    • ECOSYSTEM: ≥ 3.0.0, < 3.0.15

    Update to 3.0.15

  • cakephp/cakephp Packagist

    Versions
    • 3.1.0
    • 3.1.1
    • 3.1.2
    • 3.1.3
    Affected ranges
    • ECOSYSTEM: ≥ 3.1.0, < 3.1.4

    Update to 3.1.4

Original sources

Check your server →