GHSA-p9mp-vq4v-v5m5
GHSA-p9mp-vq4v-v5m5 · eZ Publish Legacy Passwordless login for LDAP users
This page contains facts from public vulnerability sources. Check the original advisory before updating.
This security advisory fixes a vulnerability in eZ Publish Legacy, and we recommend that you install it as soon as possible if you are using Legacy. Installations that are using the legacy LDAP login handler or the TextFile login handler in combination with the standard legacy login handler, may in rare cases be vulnerable to a failure of the standard login handler to verify passwords correctly, allowing unauthorised access. If your installation has never used the LDAP or TextFile login handlers, or never used legacy login at all, then it is not affected. Still, we recommend installing the update, to be on the safe side. To install, use Composer to update to one of the "Resolving versions" mentioned above, or apply this patch manually: https://github.com/ezsystems/ezpublish-legacy/commit/13f03a2be6c0ee4d0caaafaef05904ea9b0c4d9d
Fix available
- Published
- Updated
Stack: php
Affected products and versions
ezsystems/ezpublish-legacy Packagist
- Versions
- v2018.09.0
- v2018.09.1
- Affected ranges
- ECOSYSTEM: ≥ 2018.9.0, < 2018.9.1.1
Update to 2018.9.1.1
ezsystems/ezpublish-legacy Packagist
- Versions
- v2018.06.0
- v2018.06.1
- v2018.06.1.1
- Affected ranges
- ECOSYSTEM: ≥ 2018.6.0, < 2018.6.1.2
Update to 2018.6.1.2
ezsystems/ezpublish-legacy Packagist
- Versions
- 2013.04.0
- v2013.05.0
- v2013.06.0
- v2013.07.0
- v2013.07.1
- v2013.07.3
- v2013.09.0
- v2013.11
- v2014.01.0
- v2014.01.1
- v2014.01.2
- v2014.03.1
- v2014.03.2
- v2014.05.0
- v2014.05.1
- v2014.05.2
- v2014.07.0
- v2014.07.1
- v2014.07.2
- v2014.11.0
- v2014.11.1
- v2014.11.2
- v2015.01.0
- v2015.01.1
- v2015.01.2
- v2015.01.3
- v2017.08.0
- v2017.08.1
- v2017.08.1.1
- v2017.10.0
- v2017.10.0-RC1
- v2017.10.1
- v2017.12.0
- v2017.12.1
- v2017.12.1.1
- v2017.12.2
- v2017.12.2.1
- v2017.12.2.2
- v2017.12.3
- v2017.12.3.1
- v2017.12.3.2
- v2017.12.4
- Affected ranges
- ECOSYSTEM: ≥ 2011.0.0, < 2017.12.4.1
Update to 2017.12.4.1
ezsystems/ezpublish-legacy Packagist
- Affected ranges
- ECOSYSTEM: ≥ 5.4.0, < 5.4.12.1
Update to 5.4.12.1
ezsystems/ezpublish-legacy Packagist
- Affected ranges
- ECOSYSTEM: ≥ 5.3.0, < 5.3.12.4
Update to 5.3.12.4
Original sources
- https://github.com/ezsystems/ezpublish-legacy/pull/1394
- https://github.com/ezsystems/ezpublish-legacy/commit/01930a95637389301f762be1439f726013e58aba
- https://github.com/FriendsOfPHP/security-advisories/blob/master/ezsystems/ezpublish-legacy/2018-10-31-1.yaml
- https://github.com/ezsystems/ezpublish-legacy
- https://issues.ibexa.co/browse/EZP-29703
- https://web.archive.org/web/20201027063527/https://magento.com/security/news/new-zend-framework-1-security-vulnerability
- https://web.archive.org/web/20210614184552/https://share.ez.no/community-project/security-advisories/ezsa-2018-005-passwordless-login-for-ldap-users
- https://osv.dev/vulnerability/GHSA-p9mp-vq4v-v5m5