p PatchFirst

GHSA-q42p-pg8m-cqh6

GHSA-q42p-pg8m-cqh6 · Prototype Pollution in handlebars

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Versions of `handlebars` prior to 4.0.14 are vulnerable to Prototype Pollution. Templates may alter an Objects' prototype, thus allowing an attacker to execute arbitrary code on the server. ## Recommendation For handlebars 4.1.x upgrade to 4.1.2 or later. For handlebars 4.0.x upgrade to 4.0.14 or later.

CVSS 7.3 · High · Fix available

Published
Updated

Stack: node

Affected products and versions

  • handlebars npm

    Affected ranges
    • SEMVER: ≥ 4.1.0, < 4.1.2

    Update to 4.1.2

  • handlebars npm

    Affected ranges
    • SEMVER: ≥ 4.0.0, < 4.0.14

    Update to 4.0.14

  • handlebars npm

    Affected ranges
    • SEMVER: < 3.0.7

    Update to 3.0.7

Original sources

Check your server →