p PatchFirst

GHSA-q4gf-8mx6-v5v3

GHSA-q4gf-8mx6-v5v3 · Next.js has a Denial of Service with Server Components

This page contains facts from public vulnerability sources. Check the original advisory before updating.

A vulnerability affects certain React Server Components packages for versions 19.x and frameworks that use the affected packages, including Next.js 13.x, 14.x, 15.x, and 16.x using the App Router. The issue is tracked upstream as [CVE-2026-23869](https://github.com/facebook/react/security/advisories/GHSA-479c-33wc-g2pg). You can read more about this advisory our [this changelog](https://vercel.com/changelog/summary-of-cve-2026-23869). A specially crafted HTTP request can be sent to any App Router Server Function endpoint that, when deserialized, may trigger excessive CPU usage. This can result in denial of service in unpatched environments.

CVSS 7.5 · High · Fix available

Published
Updated

Stack: node

Affected products and versions

  • next npm

    Affected ranges
    • SEMVER: ≥ 13.0.0, < 15.5.15

    Update to 15.5.15

  • next npm

    Affected ranges
    • SEMVER: ≥ 16.0.0-beta.0, < 16.2.3

    Update to 16.2.3

Original sources

Check your server →