p PatchFirst

GHSA-q79m-c546-2g63

GHSA-q79m-c546-2g63 · CakePHP vulnerable to Denial of Service attack through XML payloads

This page contains facts from public vulnerability sources. Check the original advisory before updating.

RequestHandlerComponent had a vulnerability that would allow well crafted requests to create a denial of service attack. RequestHandlerComponent leverages `Xml::build()` which allows reading local files. We recommend that all applications using RequestHandlerComponent upgrade, or disable parsing XML payloads.

Fix available

Published
Updated

Stack: php

Affected products and versions

  • cakephp/cakephp Packagist

    Versions
    • 3.0.0
    • 3.0.1
    • 3.0.2
    • 3.0.3
    • 3.0.4
    • 3.0.5
    Affected ranges
    • ECOSYSTEM: ≥ 3.0.0, < 3.0.6

    Update to 3.0.6

  • cakephp/cakephp Packagist

    Affected ranges
    • ECOSYSTEM: ≥ 2.0.0, < 2.0.99

    Update to 2.0.99

  • cakephp/cakephp Packagist

    Affected ranges
    • ECOSYSTEM: ≥ 2.1.0, < 2.1.99

    Update to 2.1.99

  • cakephp/cakephp Packagist

    Affected ranges
    • ECOSYSTEM: ≥ 2.2.0, < 2.2.99

    Update to 2.2.99

  • cakephp/cakephp Packagist

    Affected ranges
    • ECOSYSTEM: ≥ 2.3.0, < 2.3.99

    Update to 2.3.99

  • cakephp/cakephp Packagist

    Versions
    • 2.4.10
    • 2.4.5
    • 2.4.6
    • 2.4.7
    • 2.4.8
    • 2.4.9
    Affected ranges
    • ECOSYSTEM: ≥ 2.4.0, < 2.4.99

    Update to 2.4.99

  • cakephp/cakephp Packagist

    Versions
    • 2.5.0
    • 2.5.1
    • 2.5.2
    • 2.5.3
    • 2.5.4
    • 2.5.5
    • 2.5.6
    • 2.5.7
    • 2.5.8
    • 2.5.9
    Affected ranges
    • ECOSYSTEM: ≥ 2.5.0, < 2.5.90

    Update to 2.5.90

  • cakephp/cakephp Packagist

    Versions
    • 2.6.0
    • 2.6.1
    • 2.6.2
    • 2.6.3
    • 2.6.4
    • 2.6.5
    Affected ranges
    • ECOSYSTEM: ≥ 2.6.0, < 2.6.6

    Update to 2.6.6

Original sources

Check your server →