GHSA-qr2g-p6q7-w82m
GHSA-qr2g-p6q7-w82m · x402 SDK Security Advisory
This page contains facts from public vulnerability sources. Check the original advisory before updating.
### Impact A security vulnerability exists in outdated versions of the x402 SDK. This vulnerability does not affect users' private keys, smart contracts, or funds. The issue impacts resource servers accepting payments on Solana when the facilitator is running a vulnerable version of the x402 SDK. ### Who Should Take Action Facilitators that process payments on Solana must upgrade the x402 SDK to the patched versions listed below. Clients are not required to upgrade. Resource servers are not required to upgrade unless they operate their own facilitator (self-facilitate). ### Patches Please update to the following package versions: * Npm: @x402/svm >= 2.6.0 * Pypi: x402 >= 2.3.0 * Go: x402 >= 2.5.0
Fix available
- Published
- Updated
Affected products and versions
@x402/svm npm
- Affected ranges
- SEMVER: < 2.6.0
Update to 2.6.0
x402 PyPI
- Versions
- 0.1.0
- 0.1.1
- 0.1.2
- 0.1.4
- 0.1.5
- 0.2.0
- 0.2.1
- 0.3.0
- 1.0.0
- 2.0.0
- 2.1.0
- 2.2.0
- Affected ranges
- ECOSYSTEM: < 2.3.0
Update to 2.3.0
github.com/coinbase/x402/go Go
- Affected ranges
- SEMVER: < 2.5.0
Update to 2.5.0