p PatchFirst

GHSA-qwvp-268g-jjm8

GHSA-qwvp-268g-jjm8 · Data Leakage Vulnerability in livewire/livewire

This page contains facts from public vulnerability sources. Check the original advisory before updating.

livewire/livewire versions greater than 2.2.4 and less than 2.2.6 are affected by a data leakage vulnerability. The `$this->validate()` method, which is expected to return only the validated dataset, was returning all properties of the Livewire component. This regression introduced a security risk, allowing unvalidated data to be exposed, which could lead to unexpected behavior and potential security issues.

Fix available

Published
Updated

Stack: php

Affected products and versions

  • livewire/livewire Packagist

    Versions
    • v2.2.5
    Affected ranges
    • ECOSYSTEM: ≥ 2.2.5, < 2.2.6

    Update to 2.2.6

Original sources

Check your server →