GHSA-r2r8-36pq-27cm
GHSA-r2r8-36pq-27cm · nzo/url-encryptor-bundle Insecure default secret key and IV allowing anyone to decrypt values
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Versions of nzo/url-encryptor-bundle prior to 5.0.1 and 4.3.2 are affected by a security vulnerability related to the lack of mandatory key and IV requirements. By default, the bundle uses the aes-256-ctr algorithm, which is susceptible to malleability attacks, potentially leading to Insecure Direct Object Reference (IDOR) vulnerabilities. Additionally, the reuse of keys enables users to decrypt and modify encrypted data if they can guess the plaintext of one ciphertext.
Fix available
- Published
- Updated
Stack: php
Affected products and versions
nzo/url-encryptor-bundle Packagist
- Versions
- v5.0.0
- Affected ranges
- ECOSYSTEM: ≥ 5.0.0, < 5.0.1
Update to 5.0.1
nzo/url-encryptor-bundle Packagist
- Versions
- 4.1.0
- 4.2.0
- 4.2.1
- v4.2.2
- v4.2.3
- v4.3.0
- v4.3.1
- Affected ranges
- ECOSYSTEM: ≥ 4.0.0, < 4.3.2
Update to 4.3.2
Original sources
- https://github.com/nayzo/NzoUrlEncryptorBundle/commit/ba3af1a9bcf3bedcc0ed5948979f482e2134da1a
- https://github.com/nayzo/NzoUrlEncryptorBundle/commit/bd8232501c12c9df1bc45b1970870ef665218581
- https://github.com/FriendsOfPHP/security-advisories/blob/master/nzo/url-encryptor-bundle/2020-05-03.yaml
- https://github.com/nayzo/NzoUrlEncryptorBundle
- https://osv.dev/vulnerability/GHSA-r2r8-36pq-27cm