p PatchFirst

GHSA-r97r-64vp-fghm

GHSA-r97r-64vp-fghm · Silverstripe XSS vulnerability via VirtualPage

This page contains facts from public vulnerability sources. Check the original advisory before updating.

A cross-site scripting vulnerability has been discovered in the VirtualPage class. This vulnerability can only be exploited if a user with CMS access has posted malicious or unescaped HTML into any of the textfields of a page which a VirtualPage refers to. This has been resolved by ensuring that VirtualPage safely escapes all field content.

CVSS 6.1 · Medium · Fix available

Published
Updated

Stack: php

Affected products and versions

  • silverstripe/cms Packagist

    Versions
    • 3.1.0
    • 3.1.1
    • 3.1.10-rc1
    • 3.1.10-rc2
    • 3.1.2
    • 3.1.2-rc1
    • 3.1.3
    • 3.1.3-rc1
    • 3.1.3-rc2
    • 3.1.4
    • 3.1.4-rc1
    • 3.1.5
    • 3.1.5-rc1
    • 3.1.6
    • 3.1.6-rc1
    • 3.1.6-rc2
    • 3.1.6-rc3
    • 3.1.7
    • 3.1.7-rc1
    • 3.1.8
    • 3.1.9
    • 3.1.9-rc1
    Affected ranges
    • ECOSYSTEM: ≥ 3.1.0, < 3.1.10

    Update to 3.1.10

Original sources

Check your server →