GHSA-rcm4-jv5g-wccm
GHSA-rcm4-jv5g-wccm · zfr authentication adapter did not verify validity of tokens
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Previous to @2ca5bb1c2f11537be8f94ca6867d8d69789e744a (release [0.1.2](https://github.com/zf-fr/zfr-oauth2-server-module/tree/0.1.2)), tokens weren't checked for validity/expiration. This potentially caused a security issue if expired tokens were not deleted after the expiration time was past, allowing anyone to still use invalidated authentication credentials.
CVSS 7.5 · High · Fix available
- Published
- Updated
Stack: php
Affected products and versions
zfr/zfr-oauth2-server-module Packagist
- Versions
- 0.1.0
- 0.1.1
- Affected ranges
- ECOSYSTEM: < 0.1.2
Update to 0.1.2
Original sources
- https://github.com/zf-fr/zfr-oauth2-server-module/issues/6
- https://github.com/zf-fr/zfr-oauth2-server-module/commit/2ca5bb1c2f11537be8f94ca6867d8d69789e744a
- https://github.com/FriendsOfPHP/security-advisories/blob/master/zfr/zfr-oauth2-server-module/2014-04-26.yaml
- https://github.com/zf-fr/zfr-oauth2-server-module
- https://github.com/zf-fr/zfr-oauth2-server-module/tree/0.1.2
- https://osv.dev/vulnerability/GHSA-rcm4-jv5g-wccm