p PatchFirst

GHSA-v8gr-m533-ghj9

GHSA-v8gr-m533-ghj9 · Vulnerable OpenSSL included in cryptography wheels

This page contains facts from public vulnerability sources. Check the original advisory before updating.

pyca/cryptography's wheels include a statically linked copy of OpenSSL. The versions of OpenSSL included in cryptography 2.5-41.0.3 are vulnerable to several security issues. More details about the vulnerabilities themselves can be found in https://www.openssl.org/news/secadv/20230908.txt. If you are building cryptography source ("sdist") then you are responsible for upgrading your copy of OpenSSL. Only users installing from wheels built by the cryptography project (i.e., those distributed on PyPI) need to update their cryptography versions.

Fix available

Published
Updated

Stack: python

Affected products and versions

  • cryptography PyPI

    Versions
    • 2.5
    • 2.6
    • 2.6.1
    • 2.7
    • 2.8
    • 2.9
    • 2.9.1
    • 2.9.2
    • 3.0
    • 3.1
    • 3.1.1
    • 3.2
    • 3.2.1
    • 3.3
    • 3.3.1
    • 3.3.2
    • 3.4
    • 3.4.1
    • 3.4.2
    • 3.4.3
    • 3.4.4
    • 3.4.5
    • 3.4.6
    • 3.4.7
    • 3.4.8
    • 35.0.0
    • 36.0.0
    • 36.0.1
    • 36.0.2
    • 37.0.0
    • 37.0.1
    • 37.0.2
    • 37.0.3
    • 37.0.4
    • 38.0.0
    • 38.0.1
    • 38.0.2
    • 38.0.3
    • 38.0.4
    • 39.0.0
    • 39.0.1
    • 39.0.2
    • 40.0.0
    • 40.0.1
    • 40.0.2
    • 41.0.0
    • 41.0.1
    • 41.0.2
    • 41.0.3
    Affected ranges
    • ECOSYSTEM: ≥ 2.5, < 41.0.4

    Update to 41.0.4

Original sources

Check your server →