GHSA-vcg6-8fxc-x5cq
GHSA-vcg6-8fxc-x5cq · silverstripe/framework allows upload of dangerous file types
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Some potentially dangerous file types exist in File.allowed_extensions which could allow a malicious CMS user to upload files that then get executed in the security context of the website. We have removed the ability to upload .css, .js, .potm, .dotm, .xltm and .jar files in the default configuration. Since allowed_extensions are synced to webserver configuration (in assets/.htaccess) automatically, this will also deny access to any existing uploads with these extensions. Review our security guidelines for the Common Web Platform and the File Security guide for SilverStripe 4 to find out how to add or remove extensions.
CVSS 8.8 · High · Fix available
- Published
- Updated
Stack: php
Affected products and versions
silverstripe/framework Packagist
- Versions
- 3.6.5
- 3.6.6-rc1
- Affected ranges
- ECOSYSTEM: ≥ 3.6.5-rc1, < 3.6.6
Update to 3.6.6
silverstripe/framework Packagist
- Versions
- 4.0.3
- Affected ranges
- ECOSYSTEM: ≥ 4.0.3-rc1, < 4.0.4
Update to 4.0.4
silverstripe/framework Packagist
- Versions
- 4.1.0
- 4.1.0-rc1
- 4.1.0-rc2
- Affected ranges
- ECOSYSTEM: ≥ 4.1.0-rc1, < 4.1.1
Update to 4.1.1
Original sources
- https://github.com/silverstripe/silverstripe-framework/commit/0408048653fafc52e02b4dbc6288e14e634ac613
- https://github.com/FriendsOfPHP/security-advisories/blob/master/silverstripe/framework/SS-2018-014-1.yaml
- https://github.com/silverstripe/silverstripe-framework
- https://www.silverstripe.org/download/security-releases/ss-2018-014
- https://osv.dev/vulnerability/GHSA-vcg6-8fxc-x5cq