p PatchFirst

GHSA-vhmj-5q9r-mm9g

GHSA-vhmj-5q9r-mm9g · BlastRADIUS also affects eduMFA

This page contains facts from public vulnerability sources. Check the original advisory before updating.

### Summary BlastRADIUS (see blastradius.fail for details) also affects eduMFA prior version 2.2.0, because the Message-Authenticator attributes were not checked. ### Details Website with the vulnerability information blastradius.fail The original vulnerability has been assigned CVE-2024-3596 Case in vince: https://kb.cert.org/vuls/id/456537 ### PoC There is no known proof-of-concept except for the attack shown in the paper from the researchers ### Impact An attacker can trigger an authentication flow with a RADIUS-backed token, intercept the RADIUS packet sent by eduMFA and modify the RADIUS server's answer, which would lead eduMFA to believe that the token is valid, even though the RADIUS servers answer was a reject.

CVSS 6.8 · Medium · Fix available

Published
Updated

Stack: python

Affected products and versions

  • edumfa PyPI

    Versions
    • 1.2.0
    • 1.3.0
    • 1.4.0
    • 1.5.0
    • 1.5.1
    • 2.0.0
    • 2.0.1
    • 2.0.2
    • 2.0.3
    • 2.1.0
    Affected ranges
    • ECOSYSTEM: < 2.2.0

    Update to 2.2.0

Original sources

Check your server →