GHSA-w37m-7fhw-fmv9
GHSA-w37m-7fhw-fmv9 · Next Server Actions Source Code Exposure
This page contains facts from public vulnerability sources. Check the original advisory before updating.
A vulnerability affects certain React packages for versions 19.0.0, 19.0.1, 19.1.0, 19.1.1, 19.1.2, 19.2.0, and 19.2.1 and frameworks that use the affected packages, including Next.js 15.x and 16.x using the App Router. The issue is tracked upstream as [CVE-2025-55183](https://www.cve.org/CVERecord?id=CVE-2025-55183). A malicious HTTP request can be crafted and sent to any App Router endpoint that can return the compiled source code of [Server Functions](https://react.dev/reference/rsc/server-functions). This could reveal business logic, but would not expose secrets unless they were hardcoded directly into [Server Function](https://react.dev/reference/rsc/server-functions) code.
CVSS 5.3 · Medium · Fix available
- Published
- Updated
Stack: node
Affected products and versions
next npm
- Affected ranges
- SEMVER: ≥ 15.0.0-canary.0, < 15.0.6
Update to 15.0.6
next npm
- Affected ranges
- SEMVER: ≥ 15.1.1-canary.0, < 15.1.10
Update to 15.1.10
next npm
- Affected ranges
- SEMVER: ≥ 15.2.0-canary.0, < 15.2.7
Update to 15.2.7
next npm
- Affected ranges
- SEMVER: ≥ 15.3.0-canary.0, < 15.3.7
Update to 15.3.7
next npm
- Affected ranges
- SEMVER: ≥ 15.4.0-canary.0, < 15.4.9
Update to 15.4.9
next npm
- Affected ranges
- SEMVER: ≥ 15.5.1-canary.0, < 15.5.8
Update to 15.5.8
next npm
- Affected ranges
- SEMVER: ≥ 15.6.0-canary.0, < 15.6.0-canary.59
Update to 15.6.0-canary.59
next npm
- Affected ranges
- SEMVER: ≥ 16.0.0-beta.0, < 16.0.9
Update to 16.0.9
next npm
- Affected ranges
- SEMVER: ≥ 16.1.0-canary.0, < 16.1.0-canary.17
Update to 16.1.0-canary.17