GHSA-w8gf-g2vq-j2f4
GHSA-w8gf-g2vq-j2f4 · amphp/http-client Denial of Service via HTTP/2 CONTINUATION Frames
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Early versions of `amphp/http-client` with HTTP/2 support (v4.0.0-rc10 to 4.0.0) will collect HTTP/2 `CONTINUATION` frames in an unbounded buffer and will not check the header size limit until it has received the `END_HEADERS` flag, resulting in an OOM crash. Later versions of `amphp/http-client` (v4.1.0-rc1 and up) depend on `amphp/http` for HTTP/2 processing and will therefore need an updated version of `amphp/http`, see [GHSA-qjfw-cvjf-f4fm](https://github.com/amphp/http/security/advisories/GHSA-qjfw-cvjf-f4fm). ## Acknowledgements Thank you to [Bartek Nowotarski](https://nowotarski.info/) for reporting the vulnerability.
CVSS 8.2 · High · Fix available
- Published
- Updated
Stack: php
Affected products and versions
amphp/http-client Packagist
- Versions
- v4.0.0
- v4.0.0-rc10
- v4.0.0-rc11
- Affected ranges
- ECOSYSTEM: ≥ 4.0.0-rc10, < 4.1.0-rc1
Update to 4.1.0-rc1