GHSA-wcv5-vrvr-3rx2
GHSA-wcv5-vrvr-3rx2 · Integer Overflow or Wraparound in TensorFlow
This page contains facts from public vulnerability sources. Check the original advisory before updating.
### Impact The Grappler component of TensorFlow is vulnerable to a denial of service via `CHECK`-failure (assertion failure) in [constant folding](https://github.com/tensorflow/tensorflow/blob/a1320ec1eac186da1d03f033109191f715b2b130/tensorflow/core/grappler/optimizers/constant_folding.cc#L963-L1035): ```cc for (const auto& output_prop : output_props) { const PartialTensorShape output_shape(output_prop.shape()); // ... } ``` The `output_prop` tensor has a shape that is controlled by user input and this can result in triggering one of the `CHECK`s in the `PartialTensorShape` constructor. This is an instance of [TFSA-2021-198](https://github.com/tensorflow/tensorflow/blob/master/tensorflow/security/advisory/tfsa-2021-198.md) (CVE-2021-41197). ### Patches We have patched the issue in GitHub commit [be7b286d40bc68cb0b56f702186cc4837d508058](https://github.com/tensorflow/tensorflow/commit/be7b286d40bc68cb0b56f702186cc4837d508058). The fix will be included in TensorFlow 2.8.0. We will also cherrypick this commit on TensorFlow 2.7.1, TensorFlow 2.6.3, and TensorFlow 2.5.3, as these are also affected and still in supported range. ### For more information Please consult [our security guide](https://github.com/tensorflow/tensorflow/blob/master/SECURITY.md) for more information regarding the security model and how to contact us with issues and questions.
CVSS 5.5 · Medium · Fix available
- Published
- Updated
Stack: python
Affected products and versions
tensorflow PyPI
- Versions
- 0.12.0
- 0.12.1
- 1.0.0
- 1.0.1
- 1.1.0
- 1.10.0
- 1.10.1
- 1.11.0
- 1.12.0
- 1.12.2
- 1.12.3
- 1.13.1
- 1.13.2
- 1.14.0
- 1.15.0
- 1.15.2
- 1.15.3
- 1.15.4
- 1.15.5
- 1.2.0
- 1.2.1
- 1.3.0
- 1.4.0
- 1.4.1
- 1.5.0
- 1.5.1
- 1.6.0
- 1.7.0
- 1.7.1
- 1.8.0
- 1.9.0
- 2.0.0
- 2.0.1
- 2.0.2
- 2.0.3
- 2.0.4
- 2.1.0
- 2.1.1
- 2.1.2
- 2.1.3
- 2.1.4
- 2.2.0
- 2.2.1
- 2.2.2
- 2.2.3
- 2.3.0
- 2.3.1
- 2.3.2
- 2.3.3
- 2.3.4
- 2.4.0
- 2.4.1
- 2.4.2
- 2.4.3
- 2.4.4
- 2.5.0
- 2.5.1
- 2.5.2
- Affected ranges
- ECOSYSTEM: < 2.5.3
Update to 2.5.3
tensorflow PyPI
- Versions
- 2.6.0
- 2.6.1
- 2.6.2
- Affected ranges
- ECOSYSTEM: ≥ 2.6.0, < 2.6.3
Update to 2.6.3
tensorflow PyPI
- Versions
- 2.7.0
- Affected ranges
- ECOSYSTEM: ≥ 2.7.0, < 2.7.1
Update to 2.7.1
tensorflow-cpu PyPI
- Versions
- 1.15.0
- 2.1.0
- 2.1.1
- 2.1.2
- 2.1.3
- 2.1.4
- 2.2.0
- 2.2.1
- 2.2.2
- 2.2.3
- 2.3.0
- 2.3.1
- 2.3.2
- 2.3.3
- 2.3.4
- 2.4.0
- 2.4.1
- 2.4.2
- 2.4.3
- 2.4.4
- 2.5.0
- 2.5.1
- 2.5.2
- Affected ranges
- ECOSYSTEM: < 2.5.3
Update to 2.5.3
tensorflow-cpu PyPI
- Versions
- 2.6.0
- 2.6.1
- 2.6.2
- Affected ranges
- ECOSYSTEM: ≥ 2.6.0, < 2.6.3
Update to 2.6.3
tensorflow-cpu PyPI
- Versions
- 2.7.0
- Affected ranges
- ECOSYSTEM: ≥ 2.7.0, < 2.7.1
Update to 2.7.1
tensorflow-gpu PyPI
- Versions
- 0.12.0
- 0.12.1
- 1.0.0
- 1.0.1
- 1.1.0
- 1.10.0
- 1.10.1
- 1.11.0
- 1.12.0
- 1.12.2
- 1.12.3
- 1.13.1
- 1.13.2
- 1.14.0
- 1.15.0
- 1.15.2
- 1.15.3
- 1.15.4
- 1.15.5
- 1.2.0
- 1.2.1
- 1.3.0
- 1.4.0
- 1.4.1
- 1.5.0
- 1.5.1
- 1.6.0
- 1.7.0
- 1.7.1
- 1.8.0
- 1.9.0
- 2.0.0
- 2.0.1
- 2.0.2
- 2.0.3
- 2.0.4
- 2.1.0
- 2.1.1
- 2.1.2
- 2.1.3
- 2.1.4
- 2.2.0
- 2.2.1
- 2.2.2
- 2.2.3
- 2.3.0
- 2.3.1
- 2.3.2
- 2.3.3
- 2.3.4
- 2.4.0
- 2.4.1
- 2.4.2
- 2.4.3
- 2.4.4
- 2.5.0
- 2.5.1
- 2.5.2
- Affected ranges
- ECOSYSTEM: < 2.5.3
Update to 2.5.3
tensorflow-gpu PyPI
- Versions
- 2.6.0
- 2.6.1
- 2.6.2
- Affected ranges
- ECOSYSTEM: ≥ 2.6.0, < 2.6.3
Update to 2.6.3
tensorflow-gpu PyPI
- Versions
- 2.7.0
- Affected ranges
- ECOSYSTEM: ≥ 2.7.0, < 2.7.1
Update to 2.7.1
Original sources
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-prcg-wp5q-rv7p
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-wcv5-vrvr-3rx2
- https://github.com/tensorflow/tensorflow/commit/be7b286d40bc68cb0b56f702186cc4837d508058
- https://github.com/tensorflow/tensorflow
- https://osv.dev/vulnerability/GHSA-wcv5-vrvr-3rx2