p PatchFirst

GHSA-wjg9-v8cf-f5q2

GHSA-wjg9-v8cf-f5q2 · silverstripe/graphql Cross-Site Request Forgery vulnerability

This page contains facts from public vulnerability sources. Check the original advisory before updating.

The GraphQL controller lacked any CSRF protection, meaning authenticated users could be forced or tricked into visiting a URL that would send a GET request to the affected web server that could mutate or destroy data without the user knowing.

CVSS 7.3 · High · Fix available

Published
Updated

Stack: php

Affected products and versions

  • silverstripe/graphql Packagist

    Versions
    • 2.0.0
    • 2.0.1
    • 2.0.2
    Affected ranges
    • ECOSYSTEM: ≥ 2.0.0, < 2.0.3

    Update to 2.0.3

Original sources

Check your server →