p PatchFirst

GHSA-wp8j-c736-c5r3

GHSA-wp8j-c736-c5r3 · TYPO3 Cross-Site Scripting Vulnerability Exploitable by Editors

This page contains facts from public vulnerability sources. Check the original advisory before updating.

It has been discovered that link tags generated by typolink functionality in the website's frontend are vulnerable to cross-site scripting - values being assigned to HTML attributes have not been parsed correctly. A valid backend user account is needed to exploit this vulnerability. As second and separate vulnerability in the filelist module of the backend user interface has been referenced with this advisory as well. Error messages being shown after using a malicious name for renaming a file are not propery encoded, thus vulnerable to cross-site scripting. A valid backend user account is needed to exploit this vulnerability.

CVSS 5.4 · Medium · Fix available

Published
Updated

Stack: php

Affected products and versions

  • typo3/cms Packagist

    Versions
    • 6.2.0
    • 6.2.1
    • 6.2.10
    • 6.2.10-rc1
    • 6.2.11
    • 6.2.12
    • 6.2.13
    • 6.2.2
    • 6.2.3
    • 6.2.4
    • 6.2.5
    • 6.2.6
    • 6.2.7
    • 6.2.8
    • 6.2.9
    Affected ranges
    • ECOSYSTEM: ≥ 6.2.0, < 6.2.14

    Update to 6.2.14

  • typo3/cms Packagist

    Versions
    • 7.0.0
    • 7.0.1
    • 7.0.2
    • 7.1.0
    • 7.2.0
    • 7.3.0
    Affected ranges
    • ECOSYSTEM: ≥ 7.0.0, < 7.3.1

    Update to 7.3.1

Original sources

Check your server →