p PatchFirst

GHSA-ww6p-q26w-fr6m

GHSA-ww6p-q26w-fr6m · phpxmlrpc/extra XSS in class documenting_xmlrpc_server

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Versions preceding 0.6.1 of the phpxmlrpc/extras project are susceptible to a Cross-Site Scripting (XSS) vulnerability. This vulnerability exists within the class documenting_xmlrpc_server when processing the GET methodName parameter.

CVSS 6.1 · Medium · Fix available

Published
Updated

Stack: php

Affected products and versions

  • phpxmlrpc/extras Packagist

    Versions
    • 0.5.1
    • 0.5.2
    • 0.6.0
    Affected ranges
    • ECOSYSTEM: < 0.6.1

    Update to 0.6.1

Original sources

Check your server →