GHSA-x86x-qhf8-f37w
GHSA-x86x-qhf8-f37w · willdurand/js-translation-bundle potential path traversal attack and remote code injection
This page contains facts from public vulnerability sources. Check the original advisory before updating.
A path traversal and a javascript code injection vulnerabilities were identified in willdurand/js-translation-bundle versions prior to 2.1.1.
CVSS 9.8 · Critical · Fix available
- Published
- Updated
Stack: php
Affected products and versions
willdurand/js-translation-bundle Packagist
- Versions
- 0.0.1
- 0.0.2
- 0.0.3
- 0.0.4
- 0.0.5
- 0.1.0
- 0.1.1
- 0.1.2
- 0.1.3
- 0.2.0
- 0.2.1
- 0.3.0
- 1.0.0
- 1.0.1
- 1.0.2
- 1.0.3
- 1.1.0
- 1.1.1
- 1.1.2
- 1.2.0
- 1.2.1
- 1.2.2
- v2.0.0
- v2.0.0-alpha1
- v2.0.0-alpha2
- v2.0.0-alpha3
- v2.0.0-alpha4
- v2.1.0
- Affected ranges
- ECOSYSTEM: < 2.1.1
Update to 2.1.1
Original sources
- https://github.com/willdurand/BazingaJsTranslationBundle/commit/7accee93569c3f3d2379f035a41ece66522801fc
- https://github.com/willdurand/BazingaJsTranslationBundle/commit/df6c0fd603c0192ebc5584991a52a1092c5f60bd
- https://github.com/FriendsOfPHP/security-advisories/blob/master/willdurand/js-translation-bundle/2014-07-29-1.yaml
- https://github.com/willdurand/BazingaJsTranslationBundle
- https://github.com/willdurand/BazingaJsTranslationBundle/releases/tag/v2.1.1
- https://osv.dev/vulnerability/GHSA-x86x-qhf8-f37w