p PatchFirst

GHSA-xjw3-5r5c-m5ph

GHSA-xjw3-5r5c-m5ph · typo3 Security fix for Flow Swift Mailer package

This page contains facts from public vulnerability sources. Check the original advisory before updating.

A remote code execution vulnerability has been found in the Swift Mailer library (swiftmailer/swiftmailer) recently. See this advisory for details. If you are not using the default mail() transport, this particular problem does not affect you. Upgrading is of course still recommended!

Fix available

Published
Updated

Stack: php

Affected products and versions

  • typo3/swiftmailer Packagist

    Versions
    • 4.1.5
    Affected ranges
    • ECOSYSTEM: ≥ 4.1.0, < 4.1.99

    Update to 4.1.99

  • typo3/swiftmailer Packagist

    Versions
    • 5.4.1
    • 5.4.2
    Affected ranges
    • ECOSYSTEM: ≥ 5.4.0, < 5.4.5

    Update to 5.4.5

Original sources

Check your server →