p PatchFirst

GHSA-xwhj-pqcg-8rcr

GHSA-xwhj-pqcg-8rcr · CakePHP vulnerable to Cross-site Scripting in some development error pages

This page contains facts from public vulnerability sources. Check the original advisory before updating.

CakePHP 3.4 prior to 3.4.14, 3.5 prior to 3.5.17, and 3.6 prior to 3.6.4 contains a cross-site-scripting (XSS) vulnerability in the development only `missing route` and `duplicate named route` error pages.

Fix available

Published
Updated

Stack: php

Affected products and versions

  • cakephp/cakephp Packagist

    Versions
    • 3.4.0
    • 3.4.1
    • 3.4.10
    • 3.4.11
    • 3.4.12
    • 3.4.13
    • 3.4.2
    • 3.4.3
    • 3.4.4
    • 3.4.5
    • 3.4.6
    • 3.4.7
    • 3.4.8
    • 3.4.9
    Affected ranges
    • ECOSYSTEM: ≥ 3.4.0, < 3.4.14

    Update to 3.4.14

  • cakephp/cakephp Packagist

    Versions
    • 3.5.0
    • 3.5.1
    • 3.5.10
    • 3.5.11
    • 3.5.12
    • 3.5.13
    • 3.5.14
    • 3.5.15
    • 3.5.16
    • 3.5.2
    • 3.5.3
    • 3.5.4
    • 3.5.5
    • 3.5.6
    • 3.5.7
    • 3.5.8
    • 3.5.9
    Affected ranges
    • ECOSYSTEM: ≥ 3.5.0, < 3.5.17

    Update to 3.5.17

  • cakephp/cakephp Packagist

    Versions
    • 3.6.0
    • 3.6.1
    • 3.6.2
    • 3.6.3
    Affected ranges
    • ECOSYSTEM: ≥ 3.6.0, < 3.6.4

    Update to 3.6.4

Original sources

Check your server →