openSUSE-SU-2022:0182-1
openSUSE-SU-2022:0182-1 · Security update for webkit2gtk3
This page contains facts from public vulnerability sources. Check the original advisory before updating.
This page shows selected source facts. See the linked advisories for the complete description and affected versions.
This update for webkit2gtk3 fixes the following issues: - Update to version 2.34.3 (bsc#1194019). - CVE-2021-30887: Fixed logic issue allowing unexpectedly unenforced Content Security Policy when processing maliciously crafted web content. - CVE-2021-30890: Fixed logic issue allowing universal cross site scripting when processing maliciously crafted web content.
Fix available
- Published
- Updated
Stack: system
Affected products and versions
webkit2gtk3 openSUSE:Leap 15.3
- Affected ranges
- ECOSYSTEM: < 2.34.3-23.3
Update to 2.34.3-23.3
Original sources
- https://lists.opensuse.org/archives/list/[email protected]/thread/FK6EK2KGH7KDPXCBN2Q3SSAVOCIXNCFX/
- https://bugzilla.suse.com/1194019
- https://www.suse.com/security/cve/CVE-2019-8766
- https://www.suse.com/security/cve/CVE-2019-8782
- https://www.suse.com/security/cve/CVE-2019-8808
- https://www.suse.com/security/cve/CVE-2019-8815
- https://www.suse.com/security/cve/CVE-2020-13753
- https://www.suse.com/security/cve/CVE-2020-27918
- https://www.suse.com/security/cve/CVE-2020-29623
- https://www.suse.com/security/cve/CVE-2020-3902
- https://www.suse.com/security/cve/CVE-2020-9802
- https://www.suse.com/security/cve/CVE-2020-9803
- https://www.suse.com/security/cve/CVE-2020-9805
- https://www.suse.com/security/cve/CVE-2020-9947
- https://www.suse.com/security/cve/CVE-2020-9948
- https://www.suse.com/security/cve/CVE-2020-9951
- https://www.suse.com/security/cve/CVE-2020-9952
- https://www.suse.com/security/cve/CVE-2021-1765
- https://www.suse.com/security/cve/CVE-2021-1788
- https://www.suse.com/security/cve/CVE-2021-1817
- https://www.suse.com/security/cve/CVE-2021-1820
- https://www.suse.com/security/cve/CVE-2021-1825
- https://www.suse.com/security/cve/CVE-2021-1826
- https://osv.dev/vulnerability/openSUSE-SU-2022:0182-1