openSUSE-SU-2026:20142-1
openSUSE-SU-2026:20142-1 · Security update for libsoup
This page contains facts from public vulnerability sources. Check the original advisory before updating.
This update for libsoup fixes the following issues: - CVE-2025-11021: Fixed out-of-bounds read in Cookie Date Handling of libsoup HTTP Library (bsc#1250562). - CVE-2026-0719: Fixed stack-based buffer overflow in NTLM authentication can lead to arbitrary code execution (bsc#1256399). - CVE-2026-0716: Fixed improper bounds handling may allow out-of-bounds read (bsc#1256418).
Fix available
- Published
- Updated
Stack: system
Affected products and versions
libsoup openSUSE:Leap 16.0
- Affected ranges
- ECOSYSTEM: < 3.6.5-160000.3.1
Update to 3.6.5-160000.3.1