openSUSE-SU-2026:21521-1
openSUSE-SU-2026:21521-1 · Security update for gimp
This page contains facts from public vulnerability sources. Check the original advisory before updating.
This update for gimp fixes the following issues: Changes in gimp: - CVE-2026-66757: signed integer overflow in `file-sgi` causes the plugin to crash when RLE-compressed SGI images are processed (bsc#1273151) - CVE-2026-66758: integer overflow in `file-fits` plugin causes a heap-based buffer overflow when crafted FITS images are processed (bsc#1273152) - CVE-2026-66759: out-of-bounds read in `file-icns` plugin causes information disclosure or crash when crafted ICNS images are processed (bsc#1273153)
Fix available
- Published
- Updated
Stack: system
Affected products and versions
gimp openSUSE:Leap 16.0
- Affected ranges
- ECOSYSTEM: < 3.0.8-bp160.6.1
Update to 3.0.8-bp160.6.1