p PatchFirst

PatchFirst · Latest vulnerabilities

pimcore/pimcore vulnerabilities · Page 2

Vulnerabilities published for pimcore/pimcore in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 135

  1. CVE-2024-32871

    High · CVSS 7.5EPSS 0.76%Fix available

    Pimcore Vulnerable to Flooding Server with Thumbnail files

    Pimcore is an Open Source Data & Experience Management Platform. The Pimcore thumbnail generation can be used to flood the server with large files. By changing the file extension or scaling factor of the requested thumbnail, attackers can create files that are much larger in file size than the original. This vulnerability is fixed in 11.2.4.

    • Update to 11.2.4
    Published Updated
  2. GHSA-vjwg-28gv-pm8h

    Medium · CVSS 6.1Fix available

    Pimcore TinyMCE Bundle - tinymce CVE-2024-29203, CVE-2024-29881

    ### Impact The TineMCE Bundle uses tinymce version 6.7.3. CVEs for this version exists for <6.8.1: https://nvd.nist.gov/vuln/detail/CVE-2024-29203 https://nvd.nist.gov/vuln/detail/CVE-2024-29881 ### Patches The package should be updated to at least 6.8.1 to avoid XSS vulnerability. ### Workarounds Upgrade pimcore to release 11.2.3 or 11.1.6.5. ### References https://nvd.nist.gov/vuln/detail/CVE-2024-29203 https://nvd.nist.gov/vuln/detail/CVE-2024-29881

    • Update to 11.1.6.5
    • Update to 11.2.3
    Published Updated
  3. CVE-2023-47637

    High · CVSS 8.8EPSS 1.22%Fix available

    SQL Injection in Admin Grid Filter API in Pimcore

    Pimcore is an Open Source Data & Experience Management Platform. In affected versions the `/admin/object/grid-proxy` endpoint calls `getFilterCondition()` on fields of classes to be filtered for, passing input from the request, and later executes the returned SQL. One implementation of `getFilterCondition()` is in `Multiselect`, which does not normalize/escape/validate the passed value. Any backend user with very basic permissions can execute arbitrary SQL statements and thus alter any data or escalate their privileges to at least admin level. This vulnerability has been addressed in version 11.1.1. Users are advised to upgrade. There are no

    • Update to 11.1.1
    Published Updated
  4. CVE-2023-38708

    Medium · CVSS 6.3EPSS 0.64%Fix available

    Pimcore Path Traversal Vulnerability in AssetController:importServerFilesAction

    Pimcore is an Open Source Data & Experience Management Platform: PIM, MDM, CDP, DAM, DXP/CMS & Digital Commerce. A path traversal vulnerability exists in the `AssetController::importServerFilesAction`, which allows an attacker to overwrite or modify sensitive files by manipulating the pimcore_log parameter.This can lead to potential denial of service---key file overwrite. The impact of this vulnerability allows attackers to: overwrite or modify sensitive files, potentially leading to unauthorized access, privilege escalation, or disclosure of confidential information. This could also cause a denial of service (DoS) if critical system files ar

    • Update to 10.6.7
    Published Updated
  5. CVE-2023-30855

    Medium · CVSS 6.5EPSS 0.8%Fix available

    Pimcore Path Traversal Vulnerability in AdminBundle/Controller/Reports/CustomReportController.php

    Pimcore is an open source data and experience management platform. Versions of Pimcore prior to 10.5.18 are vulnerable to path traversal. The impact of this path traversal and arbitrary extension is limited to creation of arbitrary files and appending data to existing files. When combined with the SQL Injection, the exported data `RESTRICTED DIFFUSION 9 / 9` can be controlled and a webshell can be uploaded. Attackers can use that to execute arbitrary PHP code on the server with the permissions of the webserver. Users may upgrade to version 10.5.18 to receive a patch or, as a workaround, apply the patch manually.

    • Update to 10.5.18
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →