p PatchFirst

PatchFirst · Latest vulnerabilities

PHP stack vulnerabilities · Page 126

Vulnerabilities published for PHP in the last 30 days: 222. Listed in the KEV catalogue: 2.

Filter vulnerabilities
PHP

Early warnings

Fresh vulnerability reports from vendor announcements and security news. These warnings do not change the security rating.

  1. php

    No fix published

    PHP: remote code execution

    According to OpenNet, PHP has a remote code execution vulnerability (CVE-2026-115560). The exact affected versions are unspecified. The report does not name a fixed version.

    What to do now: Check whether a PHP update with the fix is available and install it.

    CVE-2026-115560

Vulnerabilities: 7239

  1. CVE-2024-56412

    Medium · CVSS 4.8EPSS 0.39%Fix available

    PhpSpreadsheet vulnerable to bypass of the XSS sanitizer using the javascript protocol and special characters

    PhpSpreadsheet is a PHP library for reading and writing spreadsheet files. Versions prior to 3.7.0, 2.3.5, 2.1.6, and 1.29.7 are vulnerable to bypass of the cross-site scripting sanitizer using the javascript protocol and special characters. An attacker can use special characters, so that the library processes the javascript protocol with special characters and generates an HTML link. Versions 3.7.0, 2.3.5, 2.1.6, and 1.29.7 contain a patch for the issue.

    • Update to 1.29.7
    • Update to 2.1.6
    • Update to 2.3.5
    • Update to 3.7.0
    Published Updated
  2. CVE-2024-56411

    Medium · CVSS 4.8EPSS 0.37%Fix available

    PhpSpreadsheet has Cross-Site Scripting (XSS) vulnerability of the hyperlink base in the HTML page header

    PhpSpreadsheet is a PHP library for reading and writing spreadsheet files. Versions prior to 3.7.0, 2.3.5, 2.1.6, and 1.29.7 have a cross-site scripting (XSS) vulnerability of the hyperlink base in the HTML page header. The HTML page is formed without sanitizing the hyperlink base. Versions 3.7.0, 2.3.5, 2.1.6, and 1.29.7 contain a patch for the issue.

    • Update to 1.29.7
    • Update to 2.1.6
    • Update to 2.3.5
    • Update to 3.7.0
    Published Updated
  3. CVE-2024-56410

    Medium · CVSS 4.8EPSS 0.34%Fix available

    PhpSpreadsheet has Cross-Site Scripting (XSS) vulnerability in custom properties

    PhpSpreadsheet is a PHP library for reading and writing spreadsheet files. Versions prior to 3.7.0, 2.3.5, 2.1.6, and 1.29.7 have a cross-site scripting (XSS) vulnerability in custom properties. The HTML page is generated without clearing custom properties. Versions 3.7.0, 2.3.5, 2.1.6, and 1.29.7 contain a patch for the issue.

    • Update to 1.29.7
    • Update to 2.1.6
    • Update to 2.3.5
    • Update to 3.7.0
    Published Updated
  4. CVE-2024-56409

    High · CVSS 8.3EPSS 0.34%Fix available

    PhpSpreadsheet vulnerable to unauthorized reflected XSS in Currency.php file

    PhpSpreadsheet is a PHP library for reading and writing spreadsheet files. Versions prior to 3.7.0, 2.3.5, 2.1.6, and 1.29.7 are vulnerable to unauthorized reflected cross-site scripting in the `Currency.php` file. Using the `/vendor/phpoffice/phpspreadsheet/samples/Wizards/NumberFormat/Currency.php` script, an attacker can perform a cross-site scripting attack. Versions 3.7.0, 2.3.5, 2.1.6, and 1.29.7 contain a patch for the issue.

    • Update to 1.29.7
    • Update to 2.1.6
    • Update to 2.3.5
    • Update to 3.7.0
    Published Updated
  5. CVE-2024-56366

    High · CVSS 8.3EPSS 0.34%Fix available

    PhpSpreadsheet vulnerable to unauthorized reflected XSS in the Accounting.php file

    PhpSpreadsheet is a PHP library for reading and writing spreadsheet files. Versions prior to 3.7.0, 2.3.5, 2.1.6, and 1.29.7 are vulnerable to unauthorized reflected cross-site scripting in the `Accounting.php` file. Using the `/vendor/phpoffice/phpspreadsheet/samples/Wizards/NumberFormat/Accounting.php` script, an attacker can perform a cross-site scripting attack. Versions 3.7.0, 2.3.5, 2.1.6, and 1.29.7 contain a patch for the issue.

    • Update to 1.29.7
    • Update to 2.1.6
    • Update to 2.3.5
    • Update to 3.7.0
    Published Updated
  6. CVE-2024-56365

    High · CVSS 8.3EPSS 0.33%Fix available

    PhpSpreadsheet vulnerable to unauthorized reflected XSS in the constructor of the Downloader class

    PhpSpreadsheet is a PHP library for reading and writing spreadsheet files. Versions prior to 3.7.0, 2.3.5, 2.1.6, and 1.29.7 are vulnerable to unauthorized reflected cross-site scripting in the constructor of the `Downloader` class. Using the `/vendor/phpoffice/phpspreadsheet/samples/download.php` script, an attacker can perform a cross-site scripting attack. Versions 3.7.0, 2.3.5, 2.1.6, and 1.29.7 contain a patch for the issue.

    • Update to 1.29.7
    • Update to 2.1.6
    • Update to 2.3.5
    • Update to 3.7.0
    Published Updated
  7. CVE-2024-56408

    High · CVSS 8.3EPSS 0.41%Fix available

    PhpSpreadsheet allows unauthorized reflected XSS in `Convert-Online.php` file

    PhpSpreadsheet is a PHP library for reading and writing spreadsheet files. Versions prior to 3.7.0, 2.3.5, 2.1.6, and 1.29.7 have no sanitization in the `/vendor/phpoffice/phpspreadsheet/samples/Engineering/Convert-Online.php` file, which leads to the possibility of a cross-site scripting attack. Versions 3.7.0, 2.3.5, 2.1.6, and 1.29.7 contain a patch for the issue.

    • Update to 1.29.7
    • Update to 2.1.6
    • Update to 2.3.5
    • Update to 3.7.0
    Published Updated
  8. CVE-2024-56199

    Medium · CVSS 5.2EPSS 0.43%No fix published

    phpMyFAQ Vulnerable to Stored HTML Injection at FAQ

    phpMyFAQ is an open source FAQ web application. Starting no later than version 3.2.10 and prior to version 4.0.2, an attacker can inject malicious HTML content into the FAQ editor at `http[:]//localhost/admin/index[.]php?action=editentry`, resulting in a complete disruption of the FAQ page's user interface. By injecting malformed HTML elements styled to cover the entire screen, an attacker can render the page unusable. This injection manipulates the page structure by introducing overlapping buttons, images, and iframes, breaking the intended layout and functionality. Exploiting this issue can lead to Denial of Service for legitimate users, da

    Published Updated
  9. CVE-2024-56517

    Medium · CVSS 5.3EPSS 0.65%No fix published

    LGSL has a reflected XSS at /lgsl_files/lgsl_list.php

    LGSL (Live Game Server List) provides online status lists for online video games. Versions up to and including 6.2.1 contain a reflected cross-site scripting vulnerability in the `Referer` HTTP header. The vulnerability allows attackers to inject arbitrary JavaScript code, which is reflected in the HTML response without proper sanitization. When crafted malicious input is provided in the `Referer` header, it is echoed back into an HTML attribute in the application’s response. Commit 7ecb839df9358d21f64cdbff5b2536af25a77de1 contains a patch for the issue.

    Published Updated
  10. CVE-2024-56522

    High · CVSS 7.5EPSS 0.61%Fix available

    CVE-2024-56522

    An issue was discovered in TCPDF before 6.8.0. unserializeTCPDFtag uses != (aka loose comparison) and does not use a constant-time function to compare TCPDF tag hashes.

    • Update to 6.6.2+dfsg1-1+deb12u1
    • Update to 6.8.0
    • Update to 6.8.0+dfsg-1
    Published Updated
  11. CVE-2024-56520

    High · CVSS 7.3EPSS 0.56%Fix available

    CVE-2024-56520

    An issue was discovered in tc-lib-pdf-font before 2.6.4, as used in TCPDF before 6.8.0 and other products. Fonts are mishandled, e.g., FontBBox for Type 1 and TrueType fonts is misparsed.

    • Update to 2.6.4
    • Update to 6.6.2+dfsg1-1+deb12u1
    • Update to 6.8.0
    • Update to 6.8.0+dfsg-1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →