p PatchFirst

PatchFirst · Latest vulnerabilities

PHP stack vulnerabilities · Page 196

Vulnerabilities published for PHP in the last 30 days: 222. Listed in the KEV catalogue: 2.

Filter vulnerabilities
PHP

Early warnings

Fresh vulnerability reports from vendor announcements and security news. These warnings do not change the security rating.

  1. php

    No fix published

    PHP: remote code execution

    According to OpenNet, PHP has a remote code execution vulnerability (CVE-2026-115560). The exact affected versions are unspecified. The report does not name a fixed version.

    What to do now: Check whether a PHP update with the fix is available and install it.

    CVE-2026-115560

Vulnerabilities: 7239

  1. CVE-2023-31144

    Medium · CVSS 6.1EPSS 0.41%Fix available

    Craft CMS vulnerable to cross site scripting in RSS feed widget

    Craft CMS is a content management system. Starting in version 3.0.0 and prior to versions 3.8.4 and 4.4.4, a malformed title in the feed widget can deliver a cross-site scripting payload. This issue is fixed in version 3.8.4 and 4.4.4.

    • Update to 3.8.4
    • Update to 4.4.4
    Published Updated
  2. CVE-2023-30860

    High · CVSS 8EPSS 0.71%Fix available

    WWBN/AVideo stored XSS vulnerability leads to takeover of any user's account, including admin's account

    WWBN AVideo is an open source video platform. In AVideo prior to version 12.4, a normal user can make a Meeting Schedule where the user can invite another user in that Meeting, but it does not properly sanitize the malicious characters when creating a Meeting Room. This allows attacker to insert malicious scripts. Since any USER including the ADMIN can see the meeting room that was created by the attacker this can lead to cookie hijacking and takeover of any accounts. Version 12.4 contains a patch for this issue.

    • Update to 12.4
    Published Updated
  3. CVE-2023-30855

    Medium · CVSS 6.5EPSS 0.8%Fix available

    Pimcore Path Traversal Vulnerability in AdminBundle/Controller/Reports/CustomReportController.php

    Pimcore is an open source data and experience management platform. Versions of Pimcore prior to 10.5.18 are vulnerable to path traversal. The impact of this path traversal and arbitrary extension is limited to creation of arbitrary files and appending data to existing files. When combined with the SQL Injection, the exported data `RESTRICTED DIFFUSION 9 / 9` can be controlled and a webshell can be uploaded. Attackers can use that to execute arbitrary PHP code on the server with the permissions of the webserver. Users may upgrade to version 10.5.18 to receive a patch or, as a workaround, apply the patch manually.

    • Update to 10.5.18
    Published Updated
  4. DRUPAL-CONTRIB-2023-014

    Not ratedFix available

    DRUPAL-CONTRIB-2023-014

    S3 File System (s3fs) provides an additional file system to your Drupal site, which stores files in Amazon's Simple Storage Service (S3) or any other S3-compatible storage service. This module may fail to validate that a file being requested to be moved to storage was uploaded during the same web request, possibly allowing an attacker to move files that should normally be inaccessible to them. This vulnerability is mitigated by the fact that another vulnerability must already exist outside of s3fs.

    • Update to 3.2.0
    Published Updated
  5. CVE-2023-30944

    Medium · CVSS 5.6EPSS 1.14%Fix available

    Moodle: minor sql injection risk in external wiki method for listing pages

    The vulnerability was found Moodle which exists due to insufficient sanitization of user-supplied data in external Wiki method for listing pages. A remote attacker can send a specially crafted request to the affected application and execute limited SQL commands within the application database.

    • Update to 4.2.0-rc2
    Published Updated
  6. CVE-2023-30943

    Medium · CVSS 6.5EPSS 6.83%Public exploitFix available

    Moodle: tinymce loaders susceptible to arbitrary folder creation

    The vulnerability was found Moodle which exists because the application allows a user to control path of the older to create in TinyMCE loaders. A remote user can send a specially crafted HTTP request and create arbitrary folders on the system.

    • Update to 4.2.0-rc2
    Published Updated
  7. CVE-2023-30854

    High · CVSS 8.8EPSS 5.17%Fix available

    WWBN AVideo vulnerable to OS Command Injection

    AVideo is an open source video platform. Prior to version 12.4, an OS Command Injection vulnerability in an authenticated endpoint `/plugin/CloneSite/cloneClient.json.php` allows attackers to achieve Remote Code Execution. This issue is fixed in version 12.4.

    • Update to 12.4
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →