p PatchFirst

PatchFirst · Latest vulnerabilities

Web servers stack vulnerabilities · Page 14

Vulnerabilities published for Web servers in the last 30 days: 37. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Web servers

Vulnerabilities: 264

  1. CVE-2017-7668

    Critical · CVSS 9.8EPSS 57.47%Fix available

    CVE-2017-7668

    The HTTP strict parsing changes added in Apache httpd 2.2.32 and 2.4.24 introduced a bug in token list parsing, which allows ap_find_token() to search past the end of its input string. By maliciously crafting a sequence of request headers, an attacker may be able to cause a segmentation fault, or to force ap_find_token() to return an incorrect value.

    • Update to 2.4.18-2ubuntu3.3
    • Update to 2.4.25-4
    • Update to 2.4.7-1ubuntu4.16
    Published Updated
  2. CVE-2017-3169

    Critical · CVSS 9.8EPSS 19.95%Fix available

    CVE-2017-3169

    In Apache httpd 2.2.x before 2.2.33 and 2.4.x before 2.4.26, mod_ssl may dereference a NULL pointer when third-party modules call ap_hook_process_connection() during an HTTP request to an HTTPS port.

    • Update to 2.4.18-2ubuntu3.3
    • Update to 2.4.25-4
    • Update to 2.4.7-1ubuntu4.16
    Published Updated
  3. CVE-2017-3167

    Critical · CVSS 9.8EPSS 20.23%Fix available

    CVE-2017-3167

    In Apache httpd 2.2.x before 2.2.33 and 2.4.x before 2.4.26, use of the ap_get_basic_auth_pw() by third-party modules outside of the authentication phase may lead to authentication requirements being bypassed.

    • Update to 2.4.18-2ubuntu3.3
    • Update to 2.4.25-4
    • Update to 2.4.7-1ubuntu4.16
    Published Updated
  4. CVE-2016-8740

    High · CVSS 7.5EPSS 79.07%Public exploitFix available

    CVE-2016-8740

    The mod_http2 module in the Apache HTTP Server 2.4.17 through 2.4.23, when the Protocols configuration includes h2 or h2c, does not restrict request-header length, which allows remote attackers to cause a denial of service (memory consumption) via crafted CONTINUATION frames in an HTTP/2 request.

    • Update to 2.4.25-1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →