SUSE-SU-2017:0864-1
SUSE-SU-2017:0864-1 · Security update for the Linux Kernel
This page contains facts from public vulnerability sources. Check the original advisory before updating.
The SUSE Linux Enterprise 12 kernel was updated to fix the following security bugs: - CVE-2017-7184: The Linux kernel allowed local users to obtain root privileges or cause a denial of service (heap-based out-of-bounds access) via unspecified vectors, as demonstrated during a Pwn2Own competition at CanSecWest 2017 (bnc#1030573, bnc#1028372). - CVE-2017-2636: Race condition in drivers/tty/n_hdlc.c in the Linux kernel allowed local users to gain privileges or cause a denial of service (double free) by setting the HDLC line discipline (bnc#1027565).
Fix available
- Published
- Updated
Stack: system
Affected products and versions
kernel-default SUSE:Linux Enterprise Desktop 12 SP2
- Affected ranges
- ECOSYSTEM: < 4.4.49-92.14.1
Update to 4.4.49-92.14.1
kernel-source SUSE:Linux Enterprise Desktop 12 SP2
- Affected ranges
- ECOSYSTEM: < 4.4.49-92.14.1
Update to 4.4.49-92.14.1
kernel-syms SUSE:Linux Enterprise Desktop 12 SP2
- Affected ranges
- ECOSYSTEM: < 4.4.49-92.14.1
Update to 4.4.49-92.14.1
kernel-default SUSE:Linux Enterprise High Availability Extension 12 SP2
- Affected ranges
- ECOSYSTEM: < 4.4.49-92.14.1
Update to 4.4.49-92.14.1
kgraft-patch-sle12-sp2_update_6 SUSE:Linux Enterprise Live Patching 12
- Affected ranges
- ECOSYSTEM: < 1-2.1
Update to 1-2.1
kernel-default SUSE:Linux Enterprise Server for Raspberry Pi 12 SP2
- Affected ranges
- ECOSYSTEM: < 4.4.49-92.14.1
Update to 4.4.49-92.14.1
kernel-source SUSE:Linux Enterprise Server for Raspberry Pi 12 SP2
- Affected ranges
- ECOSYSTEM: < 4.4.49-92.14.1
Update to 4.4.49-92.14.1
kernel-syms SUSE:Linux Enterprise Server for Raspberry Pi 12 SP2
- Affected ranges
- ECOSYSTEM: < 4.4.49-92.14.1
Update to 4.4.49-92.14.1
kernel-docs SUSE:Linux Enterprise Software Development Kit 12 SP2
- Affected ranges
- ECOSYSTEM: < 4.4.49-92.14.3
Update to 4.4.49-92.14.3
kernel-obs-build SUSE:Linux Enterprise Software Development Kit 12 SP2
- Affected ranges
- ECOSYSTEM: < 4.4.49-92.14.1
Update to 4.4.49-92.14.1
kernel-default SUSE:Linux Enterprise Server 12 SP2
- Affected ranges
- ECOSYSTEM: < 4.4.49-92.14.1
Update to 4.4.49-92.14.1
kernel-source SUSE:Linux Enterprise Server 12 SP2
- Affected ranges
- ECOSYSTEM: < 4.4.49-92.14.1
Update to 4.4.49-92.14.1
kernel-syms SUSE:Linux Enterprise Server 12 SP2
- Affected ranges
- ECOSYSTEM: < 4.4.49-92.14.1
Update to 4.4.49-92.14.1
kernel-default SUSE:Linux Enterprise Server for SAP Applications 12 SP2
- Affected ranges
- ECOSYSTEM: < 4.4.49-92.14.1
Update to 4.4.49-92.14.1
kernel-source SUSE:Linux Enterprise Server for SAP Applications 12 SP2
- Affected ranges
- ECOSYSTEM: < 4.4.49-92.14.1
Update to 4.4.49-92.14.1
kernel-syms SUSE:Linux Enterprise Server for SAP Applications 12 SP2
- Affected ranges
- ECOSYSTEM: < 4.4.49-92.14.1
Update to 4.4.49-92.14.1
kernel-default SUSE:Linux Enterprise Workstation Extension 12 SP2
- Affected ranges
- ECOSYSTEM: < 4.4.49-92.14.1
Update to 4.4.49-92.14.1
Original sources
- https://www.suse.com/support/update/announcement/2017/suse-su-20170864-1/
- https://bugzilla.suse.com/1027565
- https://bugzilla.suse.com/1028372
- https://bugzilla.suse.com/1030573
- https://www.suse.com/security/cve/CVE-2017-2636
- https://www.suse.com/security/cve/CVE-2017-7184
- https://osv.dev/vulnerability/SUSE-SU-2017:0864-1