SUSE-SU-2022:1461-1
SUSE-SU-2022:1461-1 · Security update for nodejs12
This page contains facts from public vulnerability sources. Check the original advisory before updating.
This update for nodejs12 fixes the following issues: - CVE-2022-0778: Fixed a infinite loop in BN_mod_sqrt() reachable when parsing certificates (bsc#1196877). - CVE-2021-44906: Fixed a prototype pollution in node-minimist (bsc#1198247). - CVE-2021-44907: Fixed a potential Denial of Service vulnerability in node-qs (bsc#1197283). - CVE-2022-0235: Fixed an exposure of sensitive information to an unauthorized actor in node-fetch (bsc#1194819).
Fix available
- Published
- Updated
Stack: system
Affected products and versions
nodejs12 SUSE:Linux Enterprise Module for Web and Scripting 15 SP3
- Affected ranges
- ECOSYSTEM: < 12.22.12-150200.4.32.1
Update to 12.22.12-150200.4.32.1
nodejs12 SUSE:Linux Enterprise High Performance Computing 15 SP2-ESPOS
- Affected ranges
- ECOSYSTEM: < 12.22.12-150200.4.32.1
Update to 12.22.12-150200.4.32.1
nodejs12 SUSE:Linux Enterprise High Performance Computing 15 SP2-LTSS
- Affected ranges
- ECOSYSTEM: < 12.22.12-150200.4.32.1
Update to 12.22.12-150200.4.32.1
nodejs12 SUSE:Linux Enterprise Server 15 SP2-BCL
- Affected ranges
- ECOSYSTEM: < 12.22.12-150200.4.32.1
Update to 12.22.12-150200.4.32.1
nodejs12 SUSE:Linux Enterprise Server 15 SP2-LTSS
- Affected ranges
- ECOSYSTEM: < 12.22.12-150200.4.32.1
Update to 12.22.12-150200.4.32.1
nodejs12 SUSE:Linux Enterprise Server for SAP Applications 15 SP2
- Affected ranges
- ECOSYSTEM: < 12.22.12-150200.4.32.1
Update to 12.22.12-150200.4.32.1
nodejs12 SUSE:Manager Proxy 4.1
- Affected ranges
- ECOSYSTEM: < 12.22.12-150200.4.32.1
Update to 12.22.12-150200.4.32.1
nodejs12 SUSE:Manager Retail Branch Server 4.1
- Affected ranges
- ECOSYSTEM: < 12.22.12-150200.4.32.1
Update to 12.22.12-150200.4.32.1
nodejs12 SUSE:Manager Server 4.1
- Affected ranges
- ECOSYSTEM: < 12.22.12-150200.4.32.1
Update to 12.22.12-150200.4.32.1
nodejs12 SUSE:Enterprise Storage 7
- Affected ranges
- ECOSYSTEM: < 12.22.12-150200.4.32.1
Update to 12.22.12-150200.4.32.1
nodejs12 openSUSE:Leap 15.3
- Affected ranges
- ECOSYSTEM: < 12.22.12-150200.4.32.1
Update to 12.22.12-150200.4.32.1
nodejs12 openSUSE:Leap 15.4
- Affected ranges
- ECOSYSTEM: < 12.22.12-150200.4.32.1
Update to 12.22.12-150200.4.32.1
Original sources
- https://www.suse.com/support/update/announcement/2022/suse-su-20221461-1/
- https://bugzilla.suse.com/1194819
- https://bugzilla.suse.com/1196877
- https://bugzilla.suse.com/1197283
- https://bugzilla.suse.com/1198247
- https://www.suse.com/security/cve/CVE-2021-44906
- https://www.suse.com/security/cve/CVE-2021-44907
- https://www.suse.com/security/cve/CVE-2022-0235
- https://www.suse.com/security/cve/CVE-2022-0778
- https://osv.dev/vulnerability/SUSE-SU-2022:1461-1