SUSE-SU-2022:2071-1
SUSE-SU-2022:2071-1 · Security update for webkit2gtk3
This page contains facts from public vulnerability sources. Check the original advisory before updating.
This update for webkit2gtk3 fixes the following issues: Update to version 2.36.3 (bsc#1200106) - CVE-2022-30293: Fixed heap-based buffer overflow in WebCore::TextureMapperLayer::setContentsLayer (bsc#1199287). - CVE-2022-26700: Fixed memory corruption issue that may lead to code execution when processing maliciously crafted web content (bsc#1200106). - CVE-2022-26709: Fixed use after free issue that may lead to code execution when processing maliciously crafted web content (bsc#1200106). - CVE-2022-26716: Fixed use after free issue that may lead to code execution when processing maliciously crafted web content (bsc#1200106). - CVE-2022-26717: Fixed memory corruption issue that may lead to code execution when processing maliciously crafted web content (bsc#1200106). - CVE-2022-26719: Fixed memory corruption issue that may lead to code execution when processing maliciously crafted web content (bsc#1200106).
Fix available
- Published
- Updated
Stack: system
Affected products and versions
webkit2gtk3-soup2 SUSE:Linux Enterprise Module for Basesystem 15 SP4
- Affected ranges
- ECOSYSTEM: < 2.36.3-150400.4.3.1
Update to 2.36.3-150400.4.3.1
webkit2gtk3 SUSE:Linux Enterprise Module for Desktop Applications 15 SP4
- Affected ranges
- ECOSYSTEM: < 2.36.3-150400.4.3.1
Update to 2.36.3-150400.4.3.1
webkit2gtk4 SUSE:Linux Enterprise Module for Development Tools 15 SP4
- Affected ranges
- ECOSYSTEM: < 2.36.3-150400.4.3.1
Update to 2.36.3-150400.4.3.1
webkit2gtk3 openSUSE:Leap 15.4
- Affected ranges
- ECOSYSTEM: < 2.36.3-150400.4.3.1
Update to 2.36.3-150400.4.3.1
webkit2gtk3-soup2 openSUSE:Leap 15.4
- Affected ranges
- ECOSYSTEM: < 2.36.3-150400.4.3.1
Update to 2.36.3-150400.4.3.1
webkit2gtk4 openSUSE:Leap 15.4
- Affected ranges
- ECOSYSTEM: < 2.36.3-150400.4.3.1
Update to 2.36.3-150400.4.3.1
Original sources
- https://www.suse.com/support/update/announcement/2022/suse-su-20222071-1/
- https://bugzilla.suse.com/1199287
- https://bugzilla.suse.com/1200106
- https://www.suse.com/security/cve/CVE-2022-26700
- https://www.suse.com/security/cve/CVE-2022-26709
- https://www.suse.com/security/cve/CVE-2022-26716
- https://www.suse.com/security/cve/CVE-2022-26717
- https://www.suse.com/security/cve/CVE-2022-26719
- https://www.suse.com/security/cve/CVE-2022-30293
- https://osv.dev/vulnerability/SUSE-SU-2022:2071-1