SUSE-SU-2022:2185-1
SUSE-SU-2022:2185-1 · Security update for php7
This page contains facts from public vulnerability sources. Check the original advisory before updating.
This update for php7 fixes the following issues: - CVE-2022-31625: Fixed uninitialized pointers free in Postgres extension. (bsc#1200645) - CVE-2022-31626: Fixed buffer overflow via user-supplied password when using pdo_mysql extension with mysqlnd driver. (bsc#1200628).
Fix available
- Published
- Updated
Stack: system
Affected products and versions
php7 SUSE:Linux Enterprise Module for Package Hub 15 SP3
- Affected ranges
- ECOSYSTEM: < 7.4.6-150200.3.41.1
Update to 7.4.6-150200.3.41.1
php7 SUSE:Linux Enterprise Module for Web and Scripting 15 SP3
- Affected ranges
- ECOSYSTEM: < 7.4.6-150200.3.41.1
Update to 7.4.6-150200.3.41.1
php7 SUSE:Linux Enterprise High Performance Computing 15 SP2-ESPOS
- Affected ranges
- ECOSYSTEM: < 7.4.6-150200.3.41.1
Update to 7.4.6-150200.3.41.1
php7 SUSE:Linux Enterprise High Performance Computing 15 SP2-LTSS
- Affected ranges
- ECOSYSTEM: < 7.4.6-150200.3.41.1
Update to 7.4.6-150200.3.41.1
php7 SUSE:Linux Enterprise Server 15 SP2-BCL
- Affected ranges
- ECOSYSTEM: < 7.4.6-150200.3.41.1
Update to 7.4.6-150200.3.41.1
php7 SUSE:Linux Enterprise Server 15 SP2-LTSS
- Affected ranges
- ECOSYSTEM: < 7.4.6-150200.3.41.1
Update to 7.4.6-150200.3.41.1
php7 SUSE:Linux Enterprise Server for SAP Applications 15 SP2
- Affected ranges
- ECOSYSTEM: < 7.4.6-150200.3.41.1
Update to 7.4.6-150200.3.41.1
php7 SUSE:Manager Proxy 4.1
- Affected ranges
- ECOSYSTEM: < 7.4.6-150200.3.41.1
Update to 7.4.6-150200.3.41.1
php7 SUSE:Manager Retail Branch Server 4.1
- Affected ranges
- ECOSYSTEM: < 7.4.6-150200.3.41.1
Update to 7.4.6-150200.3.41.1
php7 SUSE:Manager Server 4.1
- Affected ranges
- ECOSYSTEM: < 7.4.6-150200.3.41.1
Update to 7.4.6-150200.3.41.1
php7 SUSE:Enterprise Storage 7
- Affected ranges
- ECOSYSTEM: < 7.4.6-150200.3.41.1
Update to 7.4.6-150200.3.41.1
php7 openSUSE:Leap 15.3
- Affected ranges
- ECOSYSTEM: < 7.4.6-150200.3.41.1
Update to 7.4.6-150200.3.41.1
php7-test openSUSE:Leap 15.3
- Affected ranges
- ECOSYSTEM: < 7.4.6-150200.3.41.1
Update to 7.4.6-150200.3.41.1
php7 openSUSE:Leap 15.4
- Affected ranges
- ECOSYSTEM: < 7.4.6-150200.3.41.1
Update to 7.4.6-150200.3.41.1