SUSE-SU-2022:2275-1
SUSE-SU-2022:2275-1 · Security update for php7
This page contains facts from public vulnerability sources. Check the original advisory before updating.
This update for php7 fixes the following issues: - CVE-2022-31625: Fixed uninitialized pointers free in Postgres extension. (bsc#1200645) - CVE-2022-31626: Fixed buffer overflow via user-supplied password when using pdo_mysql extension with mysqlnd driver. (bsc#1200628).
Fix available
- Published
- Updated
Stack: system
Affected products and versions
php7 SUSE:Linux Enterprise High Performance Computing 15-ESPOS
- Affected ranges
- ECOSYSTEM: < 7.2.5-150000.4.95.1
Update to 7.2.5-150000.4.95.1
php7 SUSE:Linux Enterprise High Performance Computing 15-LTSS
- Affected ranges
- ECOSYSTEM: < 7.2.5-150000.4.95.1
Update to 7.2.5-150000.4.95.1
php7 SUSE:Linux Enterprise High Performance Computing 15 SP1-ESPOS
- Affected ranges
- ECOSYSTEM: < 7.2.5-150000.4.95.1
Update to 7.2.5-150000.4.95.1
php7 SUSE:Linux Enterprise High Performance Computing 15 SP1-LTSS
- Affected ranges
- ECOSYSTEM: < 7.2.5-150000.4.95.1
Update to 7.2.5-150000.4.95.1
php7 SUSE:Linux Enterprise Server 15-LTSS
- Affected ranges
- ECOSYSTEM: < 7.2.5-150000.4.95.1
Update to 7.2.5-150000.4.95.1
php7 SUSE:Linux Enterprise Server 15 SP1-BCL
- Affected ranges
- ECOSYSTEM: < 7.2.5-150000.4.95.1
Update to 7.2.5-150000.4.95.1
php7 SUSE:Linux Enterprise Server 15 SP1-LTSS
- Affected ranges
- ECOSYSTEM: < 7.2.5-150000.4.95.1
Update to 7.2.5-150000.4.95.1
php7 SUSE:Linux Enterprise Server for SAP Applications 15
- Affected ranges
- ECOSYSTEM: < 7.2.5-150000.4.95.1
Update to 7.2.5-150000.4.95.1
php7 SUSE:Linux Enterprise Server for SAP Applications 15 SP1
- Affected ranges
- ECOSYSTEM: < 7.2.5-150000.4.95.1
Update to 7.2.5-150000.4.95.1
php7 SUSE:Enterprise Storage 6
- Affected ranges
- ECOSYSTEM: < 7.2.5-150000.4.95.1
Update to 7.2.5-150000.4.95.1
php7 openSUSE:Leap 15.4
- Affected ranges
- ECOSYSTEM: < 7.2.5-150000.4.95.1
Update to 7.2.5-150000.4.95.1