SUSE-SU-2022:2292-1
SUSE-SU-2022:2292-1 · Security update for php7
This page contains facts from public vulnerability sources. Check the original advisory before updating.
This update for php7 fixes the following issues: - CVE-2021-21707: Fixed a special character breaks path in xml parsing. (bsc#1193041) - CVE-2022-31625: Fixed uninitialized pointers free in Postgres extension. (bsc#1200645) - CVE-2022-31626: Fixed buffer overflow via user-supplied password when using pdo_mysql extension with mysqlnd driver. (bsc#1200628)
Fix available
- Published
- Updated
Stack: system
Affected products and versions
apache2-mod_php7 SUSE:Linux Enterprise Module for Legacy 15 SP4
- Affected ranges
- ECOSYSTEM: < 7.4.25-150400.4.8.1
Update to 7.4.25-150400.4.8.1
php7 SUSE:Linux Enterprise Module for Legacy 15 SP4
- Affected ranges
- ECOSYSTEM: < 7.4.25-150400.4.8.1
Update to 7.4.25-150400.4.8.1
php7-fastcgi SUSE:Linux Enterprise Module for Legacy 15 SP4
- Affected ranges
- ECOSYSTEM: < 7.4.25-150400.4.8.1
Update to 7.4.25-150400.4.8.1
php7-fpm SUSE:Linux Enterprise Module for Legacy 15 SP4
- Affected ranges
- ECOSYSTEM: < 7.4.25-150400.4.8.1
Update to 7.4.25-150400.4.8.1
php7-embed SUSE:Linux Enterprise Module for Package Hub 15 SP4
- Affected ranges
- ECOSYSTEM: < 7.4.25-150400.4.8.1
Update to 7.4.25-150400.4.8.1
apache2-mod_php7 openSUSE:Leap 15.4
- Affected ranges
- ECOSYSTEM: < 7.4.25-150400.4.8.1
Update to 7.4.25-150400.4.8.1
php7 openSUSE:Leap 15.4
- Affected ranges
- ECOSYSTEM: < 7.4.25-150400.4.8.1
Update to 7.4.25-150400.4.8.1
php7-embed openSUSE:Leap 15.4
- Affected ranges
- ECOSYSTEM: < 7.4.25-150400.4.8.1
Update to 7.4.25-150400.4.8.1
php7-fastcgi openSUSE:Leap 15.4
- Affected ranges
- ECOSYSTEM: < 7.4.25-150400.4.8.1
Update to 7.4.25-150400.4.8.1
php7-fpm openSUSE:Leap 15.4
- Affected ranges
- ECOSYSTEM: < 7.4.25-150400.4.8.1
Update to 7.4.25-150400.4.8.1
php7-test openSUSE:Leap 15.4
- Affected ranges
- ECOSYSTEM: < 7.4.25-150400.4.8.1
Update to 7.4.25-150400.4.8.1
Original sources
- https://www.suse.com/support/update/announcement/2022/suse-su-20222292-1/
- https://bugzilla.suse.com/1193041
- https://bugzilla.suse.com/1200628
- https://bugzilla.suse.com/1200645
- https://www.suse.com/security/cve/CVE-2021-21707
- https://www.suse.com/security/cve/CVE-2022-31625
- https://www.suse.com/security/cve/CVE-2022-31626
- https://osv.dev/vulnerability/SUSE-SU-2022:2292-1