SUSE-SU-2022:2303-1
SUSE-SU-2022:2303-1 · Security update for php8
This page contains facts from public vulnerability sources. Check the original advisory before updating.
This update for php8 fixes the following issues: - CVE-2021-21707: Fixed a special character that breaks path in xml parsing. (bsc#1193041) - CVE-2022-31625: Fixed uninitialized pointers free in Postgres extension. (bsc#1200645) - CVE-2022-31626: Fixed buffer overflow via user-supplied password when using pdo_mysql extension with mysqlnd driver. (bsc#1200628)
Fix available
- Published
- Updated
Stack: system
Affected products and versions
apache2-mod_php8 SUSE:Linux Enterprise Module for Web and Scripting 15 SP4
- Affected ranges
- ECOSYSTEM: < 8.0.10-150400.4.8.1
Update to 8.0.10-150400.4.8.1
php8 SUSE:Linux Enterprise Module for Web and Scripting 15 SP4
- Affected ranges
- ECOSYSTEM: < 8.0.10-150400.4.8.1
Update to 8.0.10-150400.4.8.1
php8-embed SUSE:Linux Enterprise Module for Web and Scripting 15 SP4
- Affected ranges
- ECOSYSTEM: < 8.0.10-150400.4.8.1
Update to 8.0.10-150400.4.8.1
php8-fastcgi SUSE:Linux Enterprise Module for Web and Scripting 15 SP4
- Affected ranges
- ECOSYSTEM: < 8.0.10-150400.4.8.1
Update to 8.0.10-150400.4.8.1
php8-fpm SUSE:Linux Enterprise Module for Web and Scripting 15 SP4
- Affected ranges
- ECOSYSTEM: < 8.0.10-150400.4.8.1
Update to 8.0.10-150400.4.8.1
php8-test SUSE:Linux Enterprise Module for Web and Scripting 15 SP4
- Affected ranges
- ECOSYSTEM: < 8.0.10-150400.4.8.1
Update to 8.0.10-150400.4.8.1
apache2-mod_php8 openSUSE:Leap 15.4
- Affected ranges
- ECOSYSTEM: < 8.0.10-150400.4.8.1
Update to 8.0.10-150400.4.8.1
php8 openSUSE:Leap 15.4
- Affected ranges
- ECOSYSTEM: < 8.0.10-150400.4.8.1
Update to 8.0.10-150400.4.8.1
php8-embed openSUSE:Leap 15.4
- Affected ranges
- ECOSYSTEM: < 8.0.10-150400.4.8.1
Update to 8.0.10-150400.4.8.1
php8-fastcgi openSUSE:Leap 15.4
- Affected ranges
- ECOSYSTEM: < 8.0.10-150400.4.8.1
Update to 8.0.10-150400.4.8.1
php8-fpm openSUSE:Leap 15.4
- Affected ranges
- ECOSYSTEM: < 8.0.10-150400.4.8.1
Update to 8.0.10-150400.4.8.1
php8-test openSUSE:Leap 15.4
- Affected ranges
- ECOSYSTEM: < 8.0.10-150400.4.8.1
Update to 8.0.10-150400.4.8.1
Original sources
- https://www.suse.com/support/update/announcement/2022/suse-su-20222303-1/
- https://bugzilla.suse.com/1193041
- https://bugzilla.suse.com/1200628
- https://bugzilla.suse.com/1200645
- https://www.suse.com/security/cve/CVE-2021-21707
- https://www.suse.com/security/cve/CVE-2022-31625
- https://www.suse.com/security/cve/CVE-2022-31626
- https://osv.dev/vulnerability/SUSE-SU-2022:2303-1