SUSE-SU-2022:2523-1
SUSE-SU-2022:2523-1 · Security update for webkit2gtk3
This page contains facts from public vulnerability sources. Check the original advisory before updating.
This update for webkit2gtk3 fixes the following issues: Update to version 2.36.4 (bsc#1201221): - CVE-2022-22662: Processing maliciously crafted web content may disclose sensitive user information. - CVE-2022-22677: The video in a webRTC call may be interrupted if the audio capture gets interrupted. - CVE-2022-26710: Processing maliciously crafted web content may lead to arbitrary code execution.
Fix available
- Published
- Updated
Stack: system
Affected products and versions
webkit2gtk3-soup2 SUSE:Linux Enterprise Module for Basesystem 15 SP4
- Affected ranges
- ECOSYSTEM: < 2.36.4-150400.4.6.2
Update to 2.36.4-150400.4.6.2
webkit2gtk3 SUSE:Linux Enterprise Module for Desktop Applications 15 SP4
- Affected ranges
- ECOSYSTEM: < 2.36.4-150400.4.6.2
Update to 2.36.4-150400.4.6.2
webkit2gtk4 SUSE:Linux Enterprise Module for Development Tools 15 SP4
- Affected ranges
- ECOSYSTEM: < 2.36.4-150400.4.6.2
Update to 2.36.4-150400.4.6.2
webkit2gtk3 openSUSE:Leap 15.4
- Affected ranges
- ECOSYSTEM: < 2.36.4-150400.4.6.2
Update to 2.36.4-150400.4.6.2
webkit2gtk3-soup2 openSUSE:Leap 15.4
- Affected ranges
- ECOSYSTEM: < 2.36.4-150400.4.6.2
Update to 2.36.4-150400.4.6.2
webkit2gtk4 openSUSE:Leap 15.4
- Affected ranges
- ECOSYSTEM: < 2.36.4-150400.4.6.2
Update to 2.36.4-150400.4.6.2